Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

This question already has an answer here:

Facebook is showing others my latest new added friends, saying something like "Aiwnas is now friends with X." Is it possible to stop Facebook from doing this? Or make it private for a customized list of my friends?

share|improve this question

marked as duplicate by Al E., jonsca Apr 5 at 20:02

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

4 Answers 4

Click on your name at the top of the page, then Activity Log, and set the filter to Friends. Use the gear menu and uncheck the places where you do not want friend activity to appear.

Activity Log Friend Activity menu

share|improve this answer
add comment

Facebook loves to change placement and/or behaviour of settings. As of March 2013, @mark4o's answer is still correct, but the way of reaching the settings is as follows:

enter image description here

share|improve this answer
    
Thanks, as of December 21, 2013 it is still the right answer :D –  dav Dec 21 '13 at 12:02
add comment

The only way to stop facebook notifying your friends of your friendship changes is to make your friends list private. Go to your friends list page. At the top right section of the page click on Edit button. There you can choose who can see list of your friends (only me, custom, friends, everyone). Whoever can see list of your friends can find out whom you just became friends with.

enter image description here

So if you need to hide friendship notifications from some of your friends you need to make a custom list.

share|improve this answer
1  
Any explanations for a negative vote?! –  Manoochehr Oct 30 '12 at 7:23
add comment

Apart from what Manoochehr has already correctly said:

Whenever you add a friend, the post would also appear at the top of your timeline, all you have to do, is edit the visibility of at post to "Only Me".

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.