Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I recently switched to a custom URL instead of a *.blogspot.com URL, but now all the comments from my posts are gone. How can I get them back?

Update: I've been waiting several days weeks and they haven't shown up yet.

share|improve this question
add comment

4 Answers

Just wait. I have heard of this happening before. It just takes some time for everything to update. So just wait a few hours and they should be back.

share|improve this answer
    
I saw people saying that too... sorry, I should have specified that I've already waited several days. –  Senseful Jul 3 '10 at 6:16
add comment

It seems a known problem, there are dozens and more requests of help in Blogger support forum.

There is an official discussion to check for updates and submit info for help.

share|improve this answer
    
That link you posted is for people that see a discrepancy between the comment count it shows and the amount of comments they actually have. –  Senseful Jul 20 '10 at 8:02
add comment

Maybe you could try this (I'm just making this up, so don't trust it too much):

  • Switch back to your blogger domain name (http://username.blogspot.com)
  • Go to the "Basic" settings page and export your blog
  • Now switch to your new domain name (http://www.yourdomainname.com)
  • Go back to the "Basic" settings page and import your blog

It's worth a shot, I suppose! Good luck!

share|improve this answer
    
That sounds dangerous! It's supposed to work without doing something like this. I'm not sure how, but it now works (without having to do the steps you posted). Good out-of-the-box thinking though. –  Senseful Jul 20 '10 at 8:11
add comment
up vote 0 down vote accepted

I'm not sure exactly which of these caused it to work, but recently I made several changes:

  • I transferred the blog ownership from a Gmail account to a Google Apps Account on the same domain.
  • Instead of forwarding the naked subdomain with a CNAME record to ghs.google.com, I switched it to use a 301 redirect from the naked subdomain to www.
  • I added MX records to the naked subdomain and started using Google Apps Mail.

... and then suddenly all my comments appeared again. It has been about 3 weeks since they first disappeared.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.