Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

Everytime I log in on a new device or browser I get the SMS text message with the 2nd step digits. It's pretty annoying. I already have the Google Authenticator to calculate my digits and it works great.

How to disable SMS?

share|improve this question
add comment

2 Answers

  1. Go to Google SMS Auth Config
    • You'll be prompted for your password even if you're already logged in
  2. Click "Remove" Next the phone number
share|improve this answer
    
As a side note. Mine is listed as a "Backup phone number". I might suggest you turn 2-factor authentication completely off and set it up again from scratch. May fix the issue and allow you to keep a "Backup Phone" in place. –  Dez Nov 15 '12 at 22:37
    
Removing phone number disables 2-step. Having a backup number as the only number lets me keep 2-step? –  yusf Nov 24 '12 at 22:11
add comment

You have to remove your primary phone number, which will disable 2-step authentication. Then, using the authenticator app from your phone, re-set up the 2-step authentication without setting a primary phone number. You can then add your phone number as a backup if you wish.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.