Web Applications Stack Exchange is a question and answer site for power users of web applications. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I signed up via my Google account, but now when I try to login via my Google account Trello just loops back to the login page. Any suggestions?


share|improve this question
Just successfully logged into Trello with my Google account. Are you sure you signed up via Google? Have you tried a different browser (maybe a cookie issue)? – DaveP Dec 29 '12 at 17:26

I had the very same problem but it was only affecting my ability to log into Trello using my Google Apps credentials AND on Google Chrome. I believe it was some strange redirect problem. In any case, I solved it as follows:

  1. Logged into Trello using FireFox and my Google Apps Credentials
  2. Opened a board
  3. Copy the URL for that board
  4. Attempt to log into Trello using Chrome
  5. Paste the URL into Chrome
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.