Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I created a filter that matches all the automated messages sent from a service, marks them as read, archives them (skips the inbox), and adds an "Automated" label.

This works great most of the time, but sometimes a colleague or customer who receives a copy of one of these messages will "reply" to one of these messages, sending their comments in a message to me. I need these replies to be treated as important, unread messages that arrive in my inbox so I won't miss them!

I have tried adding a "not from these addresses" rule to my filter to try to get it to NOT match the filter when it's from one of these addresses (colleague/customer). But this doesn't seem to work because Gmail aggregates the customer's reply into the same "conversation" and the filter has ALREADY matched and been applied to that conversation (because the earlier message(s) in the conversation were automated messages that DID match all of its criteria).

What would be a good solution be? Other ideas I've thought of...

  1. Add another filter that matches all mail sent from my customer and moves it back to the Inbox. I think this would work as long as this filter came after the other filter. The problem is, I don't see "Move to inbox" or "Mark as unread" listed as an option in the edit filter box. The only related option is "Apply the label:" but "Inbox" isn't listed as one of the label options. Am I missing something?
  2. Ask my customer to always change the subject line when replying so that Gmail won't group it in the same conversation. (This is not an acceptable solution because it relies on them to change their habits, which I have no control over...)
  3. Turn off Conversations for all my e-mail. (This is not an option, because most of the time having things grouped into conversations is helpful...)

Related posts:

share|improve this question
add comment

1 Answer 1

This answer assumes that all of the automated emails are sent from the same address.

I'm not sure how you've created your filter, but try filtering by the from: field only. If the automated sender's address is always something like no-reply@domain.com then set up your filter to filter on:

from: no-reply@domain.com

This will make sure all automated email will hit the filter. Then, when someone else replies to that address, the new sender's email will be different from the one listed in the filter, and allow it to hit the inbox as normal.

share|improve this answer
    
Thanks for the suggestion, but the message's from field is variable (the message is sent by the service on behalf of the individual so it is sent with that individual's address as the from address). –  Tyler Rick Jan 4 '13 at 19:10
    
But even if the messages WERE all from the same sender, I don't think this would solve the problem, because when the new (important) reply comes in, it automatically gets included in the existing CONVERSATION, and the CONVERSATION has ALREADY been archived because the first messages in that conversation WERE from no-reply@domain.com. Thanks again for the suggestion though. –  Tyler Rick Jan 4 '13 at 19:12
1  
Actually, when new emails are sent, the conversation will be added to your inbox as normal. Each piece of the threaded conversation is treated differently, so even if the original sender filters it out of the inbox, the new (important) sender will throw the conversation back into the inbox and mark the thread as "unread" –  OnenOnlyWalter Jan 4 '13 at 19:29
    
Also, if you are trying to filter out any email from a particular domain, then try adding a * instead of the username. Example: *@domain.com will search and filter for any user's email from that particular domain. –  OnenOnlyWalter Jan 4 '13 at 19:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.