Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I've been having an issue with GMail Chat lately.

Setting aside how annoying it is that Google Plus adds people to your chat list when you add them on Google Plus, I've been choosing to "never show" most of these people rather than blocking them. However, lately, I've noticed that a few of these users will still show up despite my expressly choosing them to never show.

Deleting the contact doesn't seem to resolve the issue. Removing the person from my G+ circles does. Is there a better fix for this?

The only chat-related GMail Lab I have enabled is right-hand chat.

share|improve this question
add comment

1 Answer 1

up vote 5 down vote accepted

The problem looks to be your integration with Google+, and the setting you have there. What you can try doing is changing the setting that automatically shows people in your circles in your chat list. Here's an article describing how to enable or disable Circles for chat.

Try this:

  1. Go to Google+ and open the chat window (probably minimized at the bottom right of the screen)
  2. Click on the drop arrow next to your name
  3. Open the privacy settings
  4. Under "Choose who can chat with you" select Custom
  5. Select which circles will allow people to be added to your chat, or deselect all to avoid it altogether

Hope this helps!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.