Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

AdSense ads are not showing after I redirected my blog to a custom domain.

How can I make it display the ads again?

share|improve this question
    
According to Googles policies, ads from different ad networks shouldn't look the same as their ads. You have an ad block from an ad network called Chitika on the bottom of your site. While Chitika's homepage says their ads look different from Google's ads, they look similar to me - I was about to comment that I can see a Google adsense unit on your blog. So maybe that is the problem, and not the domain? –  elssar Jan 10 '13 at 9:54
    
You need to get the usual approval from AdSense team for your custom domain. –  user47999 Sep 19 '13 at 15:29

4 Answers 4

There are all sorts of possibilities here.

First, inside AdSense, have you restricted the sites that your ads can be shown on? Have you added your new custom-domain to that list?

Second, when did you sign up for AdSense? If it was after early November 2012, then you probably went through the fast-track sign-up process for host-partner publishers. I'm not certain, but it's possible that with a custom domain you need to go through the full sign-up process, even though you're still publishing via a host partner. I've put some links about this into a brief description of this change, here: http://blogger-hints-and-tips.blogspot.co.uk/2012/11/simpler-but-more-limited-adsense-sign.html

Third, have you changed any aspects of your template or layout at the same time as doing the re-direction? It's possible that the AdSense problem is co-incidental. Assuming that you have ...

When I look at your blog with IE9, at the bottom I see ad-units from Chitika and Infolinks, and a square at the very bottom of the page with a "could not load" message. Looking at the page source, I can see that there is reference to an AdSense ad unit there. When I look at it in Chrome (latest version) I see a blank space there.

How did you put the AdSense ad unit in to your blog? Some options / suggestions:

A) Using Dashboard > Layout > Add a Gadget > AdSense tool inside Blogger? If so, go and ask for help in the Blogger Product Forum, this problem is likely to be about far more than just you!

B) Using Dashboard > Layout > Add a Gadget > HTML/Javascript tool inside Blogger? Are you 100% sure that you copied the ad-code correctly from AdSense and pasted it as is, with no changes, to the gadget's Content field?

C) By editing your template directly and pasting in the ad-code from AdSense? If so, did you "escape" the code before pasting it in? (I'm guessing from your blog content that you know what this means).

Fourth: I don't believe that there is any conflict with Chitika: have have AdSense and Chitika units on the same page, and don't run into problems. However I don't know about InfoLinks. Have you tried putting the AdSense ad above them, to see if the order makes a difference? (I won't solve your underlying problem, but may give some clues.)

Sorry that this is not a clear solution, but hopefully something here gives you a clue about how to proceed.

share|improve this answer
    
I checked my site properly according to your guidelines. Still I am not able to see the ads.I posted in ad sense forum also,but no use. Can you please help further to nail down this issue. –  sandeep Jan 16 '13 at 8:44
    
When did you sign up for AdSense initially? –  MaryC.fromNZ Jan 16 '13 at 14:40

This worked for me:

I had a blogger blog, and using Google's options, I redirected it to a real www.example.com domain.

Now, AdSense ads would not show up on my blog.

Solution:

  1. In Blogger dashboard, I clicked on Earnings.
  2. In the main menu, I clicked on "My Ads".
  3. The screen says, "Content > URL Channels"
  4. On this screen, I clicked "+ New URL Channel"
    1. I typed in my new URL - the new .com one I purchased.
    2. Clicked Save and Bingo! - The AdSense ads now appear on my blog.
share|improve this answer

After changing my blog from

Blogger URL: http://wereya.blogspot.com
Custom Domain URL: <http://www.wereya.com>

You don't need to correct the codes of Adsense if you add the codes onto the side-bar on your blog since the side-bar is using HTML/Javascript which is not allow xml.

But if you go to Dashboard > Design > Edit HTML (This HTML editor allows xml), you need to modify the codes of Adsense:

  1. Change & into &amp;
  2. Change < into &lt;
  3. Change > into &gt;
  4. Change " into &quot;
  5. Change ' into &apos;

For example, the blue codes below is original codes of Adsense, and the yellow codes below is what I have after changed all the symbols:

<script type="text/javascript"><!--
google_ad_client = "pub-0690220431785051";
/* 728x90, created 8/7/10 */
google_ad_slot = "8652075993";
google_ad_width = 728;
google_ad_height = 90;
//-->
</script>
<script type="text/javascript"
src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script>

&lt;script type="text/javascript"&gt;&lt;!--
google_ad_client = &quot;pub-0690220431785051";
/* 728x90, created 8/7/10 */
google_ad_slot = &quot;8652075993&quot;;
google_ad_width = 728;
google_ad_height = 90;
//--&gt;
&lt;/script&gt;
&lt;script type=&quot;text/javascript&quot;
src=&quot;http://pagead2.googlesyndication.com/pagead/show_ads.js&quot;&gt;
&lt;/script&gt;
share|improve this answer

It will work after when your new custom domain is approved from Google Adsense. your Blogspot domain may be approved but custom domain also require Approval.

share|improve this answer

protected by Community May 22 at 6:05

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.