Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I want to prevent Gmail from replacing To: i@corp.com with:

To: The fat guy who was near takeshi at the meeting <i@corp.com>

I just typed i@corp.com in the compose window, but Gmail expands it with the contact name.
I want to prevent that.
I want Gmail to use i@corp.com, or maybe i@corp.com <i@corp.com>

Sometimes I meet people and get their email but forget their name, so I write an accurate description in place of the name. But I really don't want the description sent to them:

enter image description here

I never added these names inside Gmail willingly. They are synced from my Android phone (which is not something I asked for, but seems unpreventable).

I can't edit all names, because there are thousands, and actually I need these "easy to remember" names on my Android phone, to know immediately who is calling me.

Maybe the only solution is to abandon Gmail's web interface and switch to Thunderbird?

share|improve this question
    
On your phone, People -> Menu (⋮) -> Accounts might help with the auto-sync. Or add a second Google account to your phone, and then you can create your contacts under that account. –  derobert Jan 15 '13 at 21:59
add comment

1 Answer 1

up vote 0 down vote accepted

On Android:

  1. Open the Contacts application
  2. Press the MENU key then Accounts
  3. Click on your Gmail account
  4. Uncheck Sync Contacts

Then in a web browser:

  1. Open Gmail
  2. Go to the Contacts workspace
  3. Delete all contacts, page by page.

Gmail will still expand in the Android app, but there at least you can modify the To: line manually.

(Huge thanks to derobert for the tip!)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.