Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I set up a Gmail signature under settings, and it pops up automatically when I compose a new email.

However, if someone emails me and I respond to them, it isn't automatically added to my response, which I find very inconvenient.

Any ideas?

share|improve this question

2 Answers 2

Have you had a look at the Insert this signature before quoted text in replies and remove the "--" line that precedes it option just below the signature edit box in your settings?

It’s probably that Gmail is adding your signature after the quoted text when you click reply.

Also, Gmail automatically trims content when you view emails:

The "trimmed content" is typically quoted text from a previous message (identical content) and so they hide it so what's initially visible is only the NEW content. Most people don't need to see the message they just sent that the person is replying to. They just want to see the actual reply (new content).

From Google:

Signatures are separated from the rest of your message by two dashes. To see a signature in Gmail, click the Show trimmed content button at the bottom of the message.

share|improve this answer

Check on the check box that says "Insert this signature before quoted text in replies and remove the "--" line that precedes it". Once you check the box it will definitely resolve the issue for you. The only con I noticed was that after checking the box and then sending an email to verify it showed my signature, my signature would display right underneath the email I sent. Very close to the body of the email. So to resolve this issue I went back to gmail/settings/signature and right before my signature I pressed "enter" twice and saved changes. Now my signature not only displays correctly but it's also at a good spacing distance from the body of the email. Hope this helps.

share|improve this answer

protected by Community Apr 25 at 3:09

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.