Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I know this will sound as a strange question, but I looked everywhere - and I cannot find the problem.

When I am logged in, for any google service that I use, google thinks my default language is Greek (which is not my language at all). This means the following - the whole google interface is translated to Greek - the is true for adwords, adsense, analytics, webmaster tools, recaptcha service, ... - this is not related to browser/computer as I tried other computers and browsers (firefox and chrome). - I see in any google URL that "?hl=el" is added (which forces google to use Greek) - the only way to stop this, is manually change "?hl=el" to "?hl=nl" (Dutch language) Deleting the "?hl=el" doesn't help, I need to change it.

This is related to my personal account. But I cannot find an option to change this setting. I can't remember setting this myself...

I have multiple google accounts, and this is only on one specific account (sadly, my most important - cfr adwords, adsense, analytics...).

Question is clear: how do I change this?

share|improve this question

migrated from superuser.com Feb 25 '13 at 4:44

This question came from our site for computer enthusiasts and power users.

    
google.com/webhp?hl=en –  STTR Feb 24 '13 at 23:52
add comment

3 Answers

Google provides a language setting per Google-account.

Since this page will likely be in Greek for you, I'll quote it below: https://support.google.com/accounts/bin/answer.py?hl=en&answer=32047

To change the display language for Google Accounts, you'll need to change your Google interface language:

  1. Visit your Accounts settings page. (https://www.google.com/accounts)
  2. Click the Language tab.
  3. Use the drop-down box to select your primary language, and click "Add another language" if you'd like other options.

Once you've changed your interface language, close the browser window. Then, open your browser and visit https://www.google.com/accounts/. The Google Accounts homepage should be displayed in the language you've selected.

If the interface language doesn't match the language you selected, please clear your browser's cache and cookies (http://www.google.com/support/accounts/bin/answer.py?answer=32050) and try setting the interface language again. Note that deleting your cookies will also remove your saved settings for other sites you've visited.

Keep in mind that while the Google Accounts homepage is available in all Google languages, individual Google products may not be available in all languages.

share|improve this answer
2  
+1 for realizing that the OP won't be able to see the page in a language he can understand. –  Wayne Johnston Feb 25 '13 at 0:00
add comment

https://www.google.com/settings/account - there you can set a primary language

share|improve this answer
add comment

go to https://www.google.com/preferences Now select the language tab. Change the language to English and press save.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.