Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I don't see a 'public folder' in my list. I also don't get the option of creating a 'public link' from any file: All I can click is 'share link'. The links I'm getting only work when I'm logged in to my Dropbox account, and I'm guessing they only work for me.

How can I make a public link?

share|improve this question

migrated from superuser.com Mar 11 '13 at 16:52

This question came from our site for computer enthusiasts and power users.

1  
Won't the following work? Right click --> Dropbox --> Share link –  Roney Michael Mar 11 '13 at 16:14

2 Answers 2

The Public folder was a feature in Dropbox that was later removed. It now exists only for users who've signed up before it was disabled.

For newer accounts, you can share a link to any file from any directory by clicking Share Link. You can't, however, get a direct public link from the context menu itself.

See: What is the Public folder for? - Dropbox

Please note: New Dropbox accounts created after October 4, 2012 no longer have a Public folder.

If you want your link to be public, you don't have to do anything special. In the web page that pops up once you click Share Link, make sure you click Get Link to get the public link. You could also copy the URL that's displayed in your browser (the one starting with https://www.dropbox.com/s/some-random-string/filename.

share|improve this answer
    
I did this. But these links ONLY work when I'm logged into my own dropbox account. If I'm not logged in, I get error 403. I need the link to work whether or not I'm logged in, for everybody. –  swisscy Mar 11 '13 at 16:24
    
That can't be – just click Share Link in the context menu, then Get link on the website or copy the URL. See: How do I link to a file or folder? –  slhck Mar 11 '13 at 16:29
    
ok -- I got it to work. One more problem: My pdf that opens from the link has a white border on the left. Why is that? It's not in the file. Only in the file that opens from the link. –  swisscy Mar 11 '13 at 16:40
    
It's probably because the share link embeds a frame around the file. Can you try exchanging the www.dropbox.com to dl.dropbox.com in the shared link? –  slhck Mar 11 '13 at 16:46
    
that worked. THANK YOU VERY MUCH! –  swisscy Mar 11 '13 at 16:51

Dropbox links described by slhck give you everything you need to share and preview files and folders. However, if you want to use the old system of Public Folders, click below to enable one on your account.

https://www.dropbox.com/enable_public_folder

Source: https://www.dropbox.com/help/16/en

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.