Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

Every time I copy and paste from a Google Spreadsheet, it adds a double quote before and after everything, and duplicates every single double quote.

For example, if I copy:

This is a "string" of sorts.

And paste ANYWHERE else (I can reproduce it on Windows, Mac, Linux, Notepad++, SublimeText, Xcode...) it results into:

"This is a ""string"" of sorts."

How can I copy and paste so that A" results in A" instead of "A""?

EDIT: I am talking about when you copy an entire cell, if you enter edit mode in a cell and copy the contents, the copy works fine. But you cannot copy formula-based cells this way, or multiple cells.

share|improve this question
    
I can't reproduce your results. I've taken the exact string in Google Spreadsheets and copied it to an Outlook mail (native), notepad (Window 7), all yielding the same string !! I used Crtl+C and the way to copy from within the spreadsheet. –  Jacob Jan Tuinstra Mar 12 '13 at 12:06
    
If you click the cell first and copy the contents of the cell (not the cell itself) it will work. I am having this issue specially with concatenated strings (because there are no contents to copy beside the formula). –  speeder Mar 12 '13 at 13:37
1  
Then I strongly advice you to edit your question !! –  Jacob Jan Tuinstra Mar 12 '13 at 13:40
1  
I can’t reproduce your results either. Even after you edited it. –  Alex Mar 14 '13 at 17:16
3  
I have this problem as well, it seems to happen whenever I insert a line-break. The output looks fine in the doc but the extra quotes show up when pasting. This formula should reproduce the problem: ="This is a ""string"" and "&CHAR(10)&" a linebreak" –  Ben Collier Jun 13 '13 at 16:30

2 Answers 2

The "issue" is that Google Spreadsheet is putting valid CSV-formatted data into the clipboard.

The workaround is to publish the spreadsheet to the web (File -> Publish to Web) and copy out of that document instead.

It's not much of a solution but it can save you some time.

share|improve this answer

Try pasting without formatting: Ctrl+Shift+V (or Command+Shift+V).

share|improve this answer
    
I tried here on a OSX (command+shift+v) copying to sublime text, did not worked. –  speeder Dec 9 '13 at 18:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.