Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

If I view videos on Youtube, I see the fullscreen button, as well as being able to double-click the video.

If a youtube video is embedded on a non-youtube site however, I'm missing both the button and the double-click short cut. Double click simply pause/unpauses.

This is using latest stable Chrome on Windows when logged in. If I run an incognito tab so I'm logged out, the fullscreen button appears again.

Logged in using Chrome on OSX does acts as expected. I'm using the same extensions on both OSX/Windows. Disabling all extensions has no effect.

UPDATE: Some examples

UPDATE: Here's a screenshot

enter image description here

share|improve this question
1  
I'm pretty sure that's intentional on YouTubes part (for whatever reason). It's the same way for me. –  Oliver Salzburg Mar 27 '13 at 17:23
    
I think you're right, however why I only get it on Windows and not OSX boggles my brain. –  DanH Mar 27 '13 at 23:57
    
Please leave a link to an embedded video that won't go fullscreen for testing purposes. –  karel Mar 28 '13 at 8:03
    
Okey dokey, added 2 examples. I've not foung a single non-youtube site however that lets me fullscreen in that browser. –  DanH Mar 28 '13 at 8:27
    
@DanH: That is actually very interesting, yeah. –  Oliver Salzburg Mar 28 '13 at 17:49
show 1 more comment

migrated from superuser.com Mar 28 '13 at 3:15

This question came from our site for computer enthusiasts and power users.

2 Answers

up vote 0 down vote accepted

This problem is now fixed. I think it's probably a Youtube update as I haven't restarted Chrome as far as I can remember for maybe a week but I'm sure I've seen the problem within that time.

share|improve this answer
add comment

Someone recently introduced me to the Chrome extension SmartVideo.

The extension has an option to enable the fullscreen support if it isn't provided:

enter image description here

share|improve this answer
    
Infact the problem has come back after maybe a day of not seeing it. Thanks very much I'll give this a go :) –  DanH Apr 26 '13 at 3:20
    
Unfortunately this doesn't work in my case :( –  DanH Apr 28 '13 at 4:51
    
To elaborate, a number of the settings have no effects, for instance at theverge.com/2013/4/27/4275736/…. The auto play/buffer settings do nothing as well. However the Loop all videos and Hide player settings popups do work, so the extension is clearly being loaded and doing something. –  DanH Apr 28 '13 at 5:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.