Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

Signed up for 2-step verification for my Gmail account, but didn't like it so I turned it off; only I can no longer access my account from my Kindle. Seems there is a problem with the security to my account now.

How do I restore access to my Gmail account from my Kindle?

share|improve this question
add comment

2 Answers

You will have to revoke the application specific password which you had probably setup for your Kindle. Then reauthorize the device with username, password like earlier.

Here is Google's support document on turning off two-factor authentication.

Edit: I misread your question and provided the answer which works when you have 2fA enabled!

My earlier answer: You will have to generate application specific passwords to do that. These are different from your Google Account password and are different for different devices/applications. Follow Google's instructions given here to generate the password(s).

share|improve this answer
1  
He switched off 2-step verification. Application specific passwords are only required if you have 2fA enabled. –  Sathya Apr 26 '13 at 4:42
    
Thanks @Sathya, I have edited the answer! –  Chethan S. Apr 26 '13 at 5:06
add comment

I just switched Iphones, use Gmail with two step verification and Exchange to connect my computer and my phone. I COULDN'T GET MY EXCHANGE TO WORK on my new phone and searched all over the web. Lots of others have this problem. I want to post that I found the answer.

http://support.google.com/a/bin/answer.py?hl=en&answer=2716936

Google discontinued Exchange as of 1/1/13. They have a new system now.** It was grandfathered on my old phone, but if you switch, or run a re-install, it will wipe out the Exchange you had set up. The new system is described really well in:

http://www.redmondpie.com/set-up-carddav-on-iphone-to-sync-google-gmail-contacts-without-exchange/

Make sure you use your google email address, not your "user name" under "user name". Once I moved to cardDAV and calDAV, it worked just fine.

* If you use Two Step Verification, just put in the application specific code instead of your regular Google password. **

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.