Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I've moved from Canada to Australia. I go to try and buy a Nexus 4, but it's insisting on showing me prices in the play store (google.com/nexus) for Canadian dollars. I can only find one country setting in my Google account, and that was in the Calender. Sadly, that didn't fix it. Any thoughts?

share|improve this question
    
Possible duplicate in Android Section: android.stackexchange.com/questions/42347/… –  Karan Raj Baruah May 3 '13 at 2:32
    
@KaranRajBaruah nope, have tried both the answers on that, and they didn't remedy it. Google seems to have multiple settings for the same thing all over the place, trying to find the right address to change seems to be the tricky part :/ –  Mark Mayo May 3 '13 at 2:36
    
Try clearing your cookies for the Google Play store domain? –  Hydra May 3 '13 at 14:19
    
I would recommend downloading CCleaner and obliterating everything in your cache... –  nitrl May 3 '13 at 17:23
    
Have done that, obliterated cache and all cookies. I suppose it's technically the Nexus store, not the play store, but still - nothing I do seems to let me choose Australia... –  Mark Mayo May 4 '13 at 1:59
add comment

2 Answers

Set up an additional user account and link it to an Australian credit card. The problem might be the fact that your payment information is still tied to a CAN$ card.

share|improve this answer
    
Sadly no, it's actually tied to a NZ credit card (I travel a lot) so that's not it either :/ –  Mark Mayo May 10 '13 at 0:53
add comment

Go to Google Wallet’s settings and set your home address. Base on that, Google will show the appropriate market. Probably you’ll need to clean your browser’/app’s cache and cookies as well.

share|improve this answer
    
Tried that, on multiple PCs as well. I figure there must be some other setting hiding somewhere, but still nothing :/ –  Mark Mayo Jun 2 '13 at 1:27
    
Oki, so your current setting of home address in Wallet settings (not delivery but home address) is..? Maybe it take some time for this setting to take effect.. >S –  Ewoks Jun 2 '13 at 16:03
    
I set that when I asked the question - May 3rd, and it's currently (home address) set to an Address in Australia. So it's been a month :/ –  Mark Mayo Jun 4 '13 at 2:23
    
Do you have Australian paying card (credit or so) attached to the account? –  Ewoks Jun 4 '13 at 6:41
1  
at this moment I don't know how to help.. :S I am really interested in this problem solving so please share if u find solution or reply from google support.. –  Ewoks Jun 4 '13 at 9:50
show 1 more comment

protected by Community Sep 28 '13 at 12:55

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.