Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

Related to this question, I want to remove the "On Behalf Of" when I send an email from another Gmail account via the web ui. So, as of now, my email is being shown as From emailA@gmail.com on behalf of emailB@gmail.com. When inputting the email into the settings, Gmail appears to detect that the email is another Gmail account and does not ask you whether or not to use another SMTP server. Anyone has any ideas on how I can get around this?

share|improve this question
    
Does this still happen? I was trying to reproduce this by sending from a@gmail.com as b@gmail.com to c@gmail.com, but I didn't see any message like "From b@gmail.com on behalf of a@gmail.com" in Gmail's interface. If it still does happen, then which app are you using that displays these kind of messages? –  Senseful Sep 20 '10 at 21:28
5  
Gmail is immune to it - has to do with how it reads the email headers. It's most noticeable when sending mail to an Outlook user. –  Josh Newman Sep 20 '10 at 22:58
add comment

7 Answers 7

It's a long shot, but you can try adding the account with its @googlemail.com address instead of its @gmail.com address.

(Any mail sent to userA@googlemail.com will arrive at userA@gmail.com's address.)

share|improve this answer
1  
Unfortunately this does not prompt regarding smtp either. –  Rebecca Chernoff Jul 22 '10 at 19:22
add comment

"On behalf of" problem of custom from address is already solved. You need to use the SMTP Server than Gmail server. Globinch explained this on their site.

share|improve this answer
    
Please read the question. When inputting the email into the settings, GMail appears to detect that the email is another GMail account and does not ask you whether or not to use another smtp server. –  Rebecca Chernoff Jan 8 '11 at 19:08
add comment

Lifehacker had a couple of suggestions with respect to that - try this article: Gmail removes "On behalf of" from your consolidated inbox

share|improve this answer
    
I don't see that this addresses my issue at all? –  Rebecca Chernoff Jul 26 '10 at 2:08
add comment

I hassle with this for some time now and had the same problem as you:

Gmail appears to detect that the email is another Gmail account and does not ask you whether or not to use another SMTP server.

But I found this blog posting and found the discussion in the comments very useful. If you have a "Google Apps for Business" account, you need to enable the following option:

  • go to www.google.com/a/
  • Settings -> Email -> General
  • In "Outbound relay" check "Allow users to send mail through an external SMTP when configuring a "from" address hosted outside your email domains"

It seems to take a while for that option to get activated in all your accounts. After this, you should be able to configure the external SMTP.

share|improve this answer
    
I was unable to find the option Outbound relay –  Pedro77 Feb 18 at 17:25
    
@Pedro77 make sure you use the admin console for your Google Apps for Business account. Go to google.com/a/yourdomain.com (replacing yourdomain.com with your actual registered domain), login and look for the setting as described above. This is different from the settings within the gmail app. If you are on https://mail.google.com/mail/... you're in the wrong place! –  Tim Büthe Feb 19 at 10:10
    
Ok, I was on the wrong place. Anyway, I was able to use smtp already, I think it is because the account is different from @gmail.com. –  Pedro77 Feb 19 at 13:14
add comment

Alright, I figured one way to do this. In order for this to work you need an email account without an @gmail.com address. I used a Google Apps account, but another service provider's should be fine as well (e.g. @yahoo.com, @hotmail.com, etc.). The key is, that when you press the "Next Step" button in the "Add another email address you own", it must ask you the "Send mail through your SMTP server?" question. If it does not, you must use some other email provider.

Here are the steps:

  1. Press the Send mail from another address button.
  2. For the email address, enter in a non-gmail address that you own. It doesn't mater which one you choose, no one will see it. The only thing that is important is that you can access it.
  3. Press Next Step.
  4. Choose to Send through [domain.com] SMTP servers.
  5. Enter in the credentials for the other gmail account you want to send as:
    • SMTP server: smtp.gmail.com
    • Username: example@gmail.com (the other gmail address you want to send as)
    • Password: (the password to login to the above gmail address)
    • Use SSL
    • Port: 465
  6. Press Add Account
  7. Verify the address by clicking on the link that was sent to you.
  8. Send an email message, and choose to send it as that temporary account from step 2.

Even though you chose to send as the address from step 2, it will appear as the email address you chose from step 5. This is more of a temporary workaround, since this seems like a bug in Gmail, which may be fixed sometime in the future.

share|improve this answer
    
If the sub email account is also set up such that it is checked with pop3, then you aren't able to keep the anonymous level when replying. –  Rebecca Chernoff Oct 5 '10 at 23:41
    
It works for SMTP though, thanks a lot! –  Anzeo Nov 5 '10 at 11:01
    
Alright, we deceived google, it works, but Outlook somehow defaults mail send by this method to unwanted emails. This result kinda contradicts the initial purpose since it is only Outlook which shows 'On Behalf Of' and all the trouble was for it. –  bizzz Apr 1 '13 at 13:22
add comment

OK, so this is easy, but may cost some cash.

The reason that gmail does this is that for security and to stop its servers being marked as spam it need to state the correct "From" address.

You need to specify an SMTP server that google will use to "send" your mail that will allow relays for the address you have chosen. For companies this is easy, for individuals, not so much.

if, like me, you own your own domain you can use a service like DynDNS to fix this issue. If you purchase a Mailhop Outbound account you can add their SMTP service to google for any email address you like.

Once setup in your "Send mail as" list you email will have the words "Mail is sent through: outbound.mailhop.org" under it. You can use the instructions on the Google site for configuring gmail to use this service.

This will remove that pesky "Sent on behalf of" message that we all hate for only $20 per year. Not bad.

share|improve this answer
1  
I think the question was misunderstood.. this wouldn't solve the issue. –  Fosco Sep 3 '10 at 14:01
    
It does indeed solve the exact problem defined in the question. This is how I solved it and it works just fine. The ideal solution is to use a Google Apps account as defined above, but this works regardless. –  MrHinsh Aug 9 '12 at 7:36
add comment

I used to be able to find documentation of this fact, but searches at this time turn up nothing.

Anyway, Google does not support using alternate SMTP settings for sending as another Gmail account. I'm not sure why, though; I just know they don't support it.

share|improve this answer
1  
I am looking for a workaround. –  Rebecca Chernoff Jul 27 '10 at 2:29
    
There are no workarounds that I know of. –  dgw Jul 27 '10 at 20:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.