Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I found the new Google Hangouts sounds annoying and they don't provide a way to disable them. The only thing you can do is disable notifications entirely, per contact even, not globally.

How can you just mute the sound alerts for new messages?

share|improve this question
    
You can disable them globally with the options in the drop-down next to your name. –  crdx May 31 '13 at 7:53
    
Yes, but that's only temporary, for up to 48 hours. –  bfred.it Jul 13 '13 at 1:04
add comment

3 Answers

up vote 5 down vote accepted

Google now offers an option to mute sounds:

This setting applies to all Hangouts notifications from Gmail, Google+ and the Chrome extension on the same desktop computer.

Turn sound off for notification sounds

  • Click menu ▼ at the top of your Hangouts list.
  • Check the box next to "Mute."

From: Google Hangouts - Turn off notification sounds

share|improve this answer
    
Awesome! They finally added the option! Mute wasn't there until recently. Screenshots: Before/After –  bfred.it Dec 16 '13 at 16:33
add comment

Edit 2013/12/16: they added an option to mute all sounds, indefinitely. Finally! See this answer


As of today (2013/05/21), you can't (even though it's requested), but I found a way to prevent the sound to be loaded and therefore played.

In short: I redirect the link to the alert audio file (which you can find at the bottom of the answer) to a non-existent one.

This is how:

  1. Download the extension Redirector from the Chrome Web Store
  2. visit: chrome-extension://lacckjdlmkdhcacjdodpjokfobckjclh/html/options.html#ruleMgr
  3. click on [+]
  4. set it like in this screenshot
  5. save
  6. you might have to restart Chrome (or the Hangouts extensions)

Rule editor screenshot

Text to enter:

ssl.gstatic.com/*
incoming_message_eb39ce414e3ffba41a8e173581dc7248

To see if it works, try this url, it shouldn't load

https://ssl.gstatic.com/chat/sounds/incoming_message_eb39ce414e3ffba41a8e173581dc7248.mp3
share|improve this answer
    
Someone could wrap this up in an extension but I suppose (hope) Google will fix it soon, so it's temporary. –  bfred.it May 31 '13 at 2:22
    
I'm going to try this but with adblock and just blocking the URL to the mp3. –  crdx May 31 '13 at 7:44
1  
You're totally right, crdx, you should add that as an answer! I don't know how I didn't think of that considering how many custom filters I have –  bfred.it May 31 '13 at 14:32
1  
Actually… I tried blocking it with AdBlock: it works in Gmail, but not in the Hangouts extension. Maybe AdBlock doesn't work inside chrome-extension:// pages –  bfred.it May 31 '13 at 15:10
    
Yeah, it probably doesn't. I don't use the extension so I'm just going the adblock route. I'll add it as an answer as well, anyway. –  crdx May 31 '13 at 17:39
add comment

Use your favourite adblock plugin to block the URL to the mp3, which at the time of writing is:

https://ssl.gstatic.com/chat/sounds/incoming_message_eb39ce414e3ffba41a8e173581dc7248.mp3

In Chrome this appears to only work in web interfaces, and not in the browser extension.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.