Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

On a Mac, hitting Cmd+Enter will send the current message (on Windows it is Ctrl+Enter). I’m constantly hitting this accidentally and sending emails before I’m done with them. Usually, it’s because I’m trying to press Cmd+] to indent some text, but the ] key is right next to Enter on my keyboard and I sometimes hit the wrong one.

Is there any way that I can disable this shortcut in either GMail settings or with a GreaseMonkey script/Firefox plugin?

share|improve this question
    
Related: Disable some Gmail shortcut keys –  batpigandme May 31 '13 at 14:48
    
As an alternative, I can recommend the "Undo send" lab feature. So if you accidentally send an email, you can undo it within the next 10 seconds or so. –  Vidar S. Ramdal Oct 22 '13 at 14:27
add comment

2 Answers 2

Solution for Safari using Keystroke Extension to intercept the key and do something innocuous:

  • install extension from https://sites.google.com/site/solushex/keystroke
  • click backwards KS icon (backwards text indicates key filter disabled)
  • map Command Enter to something appropriate for you or otherwise innocuous .. say Wrap Text
  • at the top of the preferences screen be sure to click the "Save" text then "Inactive" as well, toggling the filter to Active state
  • restart Safari
  • bickety bam Gmail rocks again ;)

Comment: Some advanced features like excluding keys by domain; untried

FWIW my own need scenario comes from using a lot of JetBrains tools where CMD+Enter inserts a line leaving my cursor exactly where it was on the screen and at the beginning of the new line (coding sweetness). After auto-piloting out Gmail fragments a fix was a must.

share|improve this answer
add comment

There are certain keyboard shortcuts in Gmail that are always on regardless of whether or not you've enabled Gmail keyboard shortcuts (see below). According to Gmail's keyboard shortcut help:

Shortcuts that are always turned on

These navigational and formatting shortcuts all work whether or not you've enabled the keyboard shortcuts setting.

The Cmd+Enter shortcut is one of the Gmail Keyboard Shortcuts that will always be turned on regardless of whether or not keyboard shortcuts are enabled.

You can disable Gmail keyboard shortcuts by going to Settings (the gear icon) and selecting the General tab. About half-way down you can select your Keyboard shortcuts: option and turn shortcuts on or off. Just be sure to click Save changes at the bottom and you should be all set.

If you go to Labs in the settings panel you can enable Custom keyboard shortcuts which should allow you to edit the shortcuts to your liking (keyboard shortcuts have to be enabled for this to work). See answer about this from the Disable some gmail shortcut keys thread.

share|improve this answer
    
Thanks for the clarification of CMD + Enter always being on when shortcuts are enabled, unfortunately I use many keyboard shortcuts, but I just want to disable sending one. –  Adam Franco May 31 '13 at 19:02
    
@AdamFranco yeah, unfortunately not even "custom keyboard shortcuts" allows you to override that one –  batpigandme May 31 '13 at 19:19
    
You might want to rephrase your answer because, the way you have written it, makes it sound like you can disable CMD + Enter by turning keyboard shortcuts off at the general tab. That is not the case - CMD + Enter is an always on shortcut (tested this twice to be sure). –  Francis Davey Jan 30 at 15:05
    
@FrancisDavey thanks for pointing that out, I changed it up. –  batpigandme Jan 31 at 15:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.