Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I accidentally deleted the filters for auto-archiving (skip the inbox) messages that go into my smart label (promotions, social, etc.) folders.

How can I re-enable/re-create these filters so that my inbox stops being full of these?

share|improve this question

migrated from superuser.com Jun 7 '13 at 20:33

This question came from our site for computer enthusiasts and power users.

add comment

3 Answers 3

up vote 5 down vote accepted

I deleted my Promotions labels thinking I wouldn't need it anymore but I prefer it over the new inbox so I searched a little and this seems to have worked:

  1. Create a new label with the same name as the Smart Filter, in my case "Promotions"

  2. Create a new filter and enter the value "label:^smartlabel_promo" in the "Has the words" field. When you do a sample filter search, that value becomes "category:promotions" automatically

  3. Save the filter and the Smart Label for Promotions should be restored

Source for #2: http://productforums.google.com/d/msg/gmail/Tly7NqKJ0_I/_1-w1AKv5VkJ

share|improve this answer
    
Looks like it's working! Thank you :D –  Erty Sep 29 '13 at 20:38
add comment

While these seem to be redundant with the new default Inbox, and I won't be surprised if they're removed from the Gmail Labs in the future, it is possible to recreate them.

To test, I decided to munge my own email account. I deleted one of the SmartLabel filters.

To restore, I did this:

  1. Turn off the SmartLabels in Gmail Labs; Save your settings
    • You'll be prompted whether you want to get rid of the labels that go along with them. I chose to delete them, but you probably won't want to. (In the end it doesn't seem to matter.)
  2. Turn on the SmartLabels again; Save your settings

Labels and filters are re-created. Now you can check that "Archive incoming..." checkbox that appears with the SmartLabel labels.

You will, of course, want to use the "Priority Inbox", not the "Default" inbox, otherwise you may get some unusual results.

share|improve this answer
add comment

It is very easy. Go to your smart label from label list on the left side, and choose "archive incoming Promotions(skip the inbox) on the right top side.

share|improve this answer
    
I seem to have some sort of new inbox, and that doesn't work anymore - the option is gone. –  Erty Jun 6 '13 at 18:45
    
i have the new inbox, the option "archive incoming Promotions(skip the inbox)" on the right top corner of the mail list, below the gear icon. –  zgjie Jun 7 '13 at 6:46
    
Hmm... doesn't exist for me. Thanks for trying to help out, though! –  Erty Jun 7 '13 at 7:16
    
see here lifehacker.com/5985689/… –  zgjie Jun 7 '13 at 7:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.