Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

Somewhat recently, Gmail started automatically labeling new messages as "Social", "Promotions", "Updates", or "Forums". These labels clash with those that I already have, and Gmail isn't categorizing them right anyway. I want them gone.

Under [gear image]->Configure Inbox, I found "Select tabs to enable". I unchecked everything except for "Primary", which can't be.

Under [gear icon]->Settings->Labels (or [any message]->[label icon]->Manage labels), I can find under "Categories" the undesired labels. I toggled both columns to "hide".

Despite all this, they still appear at the bottom of the label list for each message, and Gmail still tags incoming new messages with them. To properly categorize new messages, I first need to uncheck any of these tags Gmail adds, and then add my own. After unchecking, they're still in the label list:

I want these silly things gone entirely. How can I get rid of them?

share|improve this question

migrated from superuser.com Jun 14 '13 at 3:57

This question came from our site for computer enthusiasts and power users.

add comment

2 Answers 2

That's part of the new inbox announced 29-May.

To revert back:

Click the Gear icon and go into Settings.

On the Inbox tab, change the "Inbox type:" to be something besides the default. You probably want "Priority Inbox".

share|improve this answer
    
I was unaware of these changes. I was able to find a different configuration that was acceptable, but unfortunately the objectionable labels remain. A content-free test email was not automatically categorized. The same results occur with the "Priority Inbox".\n\nInterestingly, though the labels appear in each message's available labels, they do not appear in the list "Show all from label" when customizing the inbox on the suggested page. Thanks, –  Ian Mallett Jun 14 '13 at 3:08
    
Subsequent emails confirm that Gmail still automatically flags at least some incoming messages with these labels. –  Ian Mallett Jun 14 '13 at 3:39
add comment
up vote 1 down vote accepted

A listing of other users expressing (various degrees of) outrage over the same topic can be found here. As before, the accepted solution doesn't work.

However, one person found a temporary solution using Adblock Plus (here, first message on Jun 26 (of 2013, I assume)):

It's not a problem to do this at all: go to ABP filter preferences, then select "Custom Filters" tab, then "Element Hiding Rules", then click "Add Filter". Now add following eight filters:

mail.google.com##.J-N[title="Social"]
mail.google.com##.J-N[title="Promotions"]
mail.google.com##.J-N[title="Updates"]
mail.google.com##.J-N[title="Forums"]
mail.google.com##.J-LC[title="Social"]
mail.google.com##.J-LC[title="Promotions"]
mail.google.com##.J-LC[title="Updates"]
mail.google.com##.J-LC[title="Forums"]

This seems to work for me. It's really regrettable, since the data is still there, the problem is still there, and this is really just a workaround that may break if Google changes the website's underlying code.

Still, in light of the fact that the "correct" solution to the problem doesn't seem to fix anything, there's not much else I can do. This temporary solution is permanent for me, unless Google can fix the underlying problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.