Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

A few weeks ago, YouTube started showing half of their videos in HTML5 player for me. Is there a way to force it back to using Flash player only (in Chrome)?

(I'm opted out of HTML5 trial at http://www.youtube.com/html5.)

share|improve this question

migrated from superuser.com Jun 18 '13 at 17:26

This question came from our site for computer enthusiasts and power users.

1  
In youtube.com/html5 page click the Leave HTML5 Beta link at the bottom. Clear all browser history, cache, etc. –  Tiago CA Jun 1 '13 at 23:17
    
@Tiago I'm not in the beta, I have "Join" button, not "Leave" –  serg555 Jun 1 '13 at 23:46
    
try adding "&html5=false" to the end of your youtube url. This is only a temporary fix though –  Cybertox Jun 2 '13 at 0:57
    
@Cybertox Doesn't seem to work for me. –  serg555 Jun 2 '13 at 1:49
    
Switch to Opera. That worked for me –  user50984 Oct 25 '13 at 0:18

5 Answers 5

up vote 4 down vote accepted

First join the trial, and then leave it. Leaving the trial is the only way to force YouTube to remember you want the videos played in Flash, but of course to do that you have to join the trial first. It fixed the issue for me.

share|improve this answer
    
wow! who would you knew :D Thanks! –  GianPaJ Jul 21 '13 at 12:42
7  
apparently this doesn't work anymore –  GianPaJ Oct 13 '13 at 21:00
    
I can confirm it doesn't, which is really annoying because the html5 player just doesn't work for me on Ubuntu. –  Gerry Nov 18 '13 at 14:16
1  
Here's how I enforced my dominion over Chrome: Find the file called ffmpegsumo.dll where Chrome is installed (C:\Program Files (x86)\Google\Chrome\Application\30.xxxxx\ for me). Delete it or move it out of that folder. I also moved nacl_irt_*.nexe. –  Wayne Bloss Nov 27 '13 at 21:27

As described here if you use the Chrome browser, install YouTube Options and specify the codec as Flash.

By default YouTube options will also change a bunch other aspects of the YouTube interface (e.g., hiding comments, video descriptions, ads, etc.). You may like this, but you may also want to modify some of this plugin behaviour if for example, you like video descriptions.

share|improve this answer

Try deleting your Flash cookies. http://macromedia.com/support/documentation/en/flashplayer/help/settings_manager07.html

I had the same issue, in fact I just came here because I was googling for a solution. I noticed that videos that would play in HTML5 on Chrome would play in Flash in Firefox even if I was signed in to Youtube on both browsers so I figured that it was a cookie thing. Deleting my regular Youtube cookies didn't do anything but I just cleared my Flash cookies and videos that were HTML5 are now Flash again.

share|improve this answer
    
I deleted data for all websites in the storage manager but still getting HTML5 videos on YouTube. –  Erik Allik Oct 28 '13 at 20:09
1  
It's randomly returned for me and another deletion of my Flash cookies didn't fix it. I did find this userscript (scroll down for Chrome extension version) that can force Flash among other things, though: userscripts.org/scripts/show/114002 –  Bonkwisha Nov 8 '13 at 19:43
    
@Bonkwisha - That userscript is exactly the solution. If I could upvote twice your comment I would. –  dsm Jan 8 at 18:07

After leaving the trial and clearing the cache and cookies, you must also go to Chrome's Extensions page (chrome://extensions) and disable the extension "HTML5 Video for YouTube" (and possibly "YouTube Options" for good measure)

share|improve this answer

After a whise wandering in forums I found this: https://chrome.google.com/webstore/detail/html5-video-for-youtube/dolajcekhnohkpncmhgledbmndjpblei This doesn't solve the problem, it's a workaround, but it works.

share|improve this answer

protected by Community Nov 9 '13 at 15:20

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.