Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I've tried to find a way to enable 2 factor authentication for login to the Google Apps management console (admin.google.com), but can't seem to find it. (I already have 2 factor auth for my users on the domain, so it is not for domain users but for the admin console I want to enable it.)

Have googled for it and searched here also, but can't seem to find the answer/way to enable it.

Can anyone help, please?

share|improve this question

1 Answer 1

up vote 4 down vote accepted
+50

Based on my own testing, it seems that Google Apps users who have enabled 2-factor authentication for their account will also be required to input a verification code when logging into the management console. This has two key implications:

  1. The only way to enforce 2-factor authentication for the management console is by ensuring that all users who can access the console have 2-factor auth enabled. As I understand it, it's not possible to force your users to enable this feature, the only thing you can do is choose to make the feature available to them (or not, obviously) and encourage all users to enable it.
  2. Any user who has asked for their device to be 'remembered' when logging in using 2-factor auth will not be required to enter a verification code to log into the management console unless they clear their cookies or use a different device.

In summary, 2-factor auth works as expected with the management console, but it must be enabled on a per-user basis.

Assuming that you have enabled 2-factor auth for your Google apps account, you can test the above by logging into the console from an Incognito window or an alternative browser. It should then ask you for a verification code as expected.

share|improve this answer
1  
Thanks, James. Very odd, because I don't remember having seen the 2 -factor auth when logging in to the management console, but doing it in an incognito window as you suggested, I got the 2-factor code prompt. –  rassom Jul 2 '13 at 19:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.