Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I'm able to configure Sitefinity CMS for use with ActiveDirectory for administrative logins following instructions found on the Sitefinity knowledgebase. This is what I have for a configuration:

<connectionStrings>
    <add name="IowaDomain" connectionString="LDAP://iowa.uiowa.edu" />
</connectionStrings>
....
<roleManager enabled="true" cacheRolesInCookie="true" defaultProvider="Sitefinity">
    <providers>
        <clear />
        <add connectionStringName="DefaultConnection" applicationName="/" name="Public" type="Telerik.DataAccess.AspnetProviders.TelerikRoleProvider, Telerik.DataAccess" />
        <add name="Sitefinity"
             type="Telerik.Security.ActiveDirectory.TelerikADRoleProvider, Telerik.Security"
             connectionStringName="IowaDomain" 
             connectionUsername="******" 
             connectionPassword="******" 
             groupMaps="ITS-CTS-Sitefinity-Admins"
             domainName="iowa.uiowa.edu" 
       />
    </providers>
</roleManager>
<membership defaultProvider="Sitefinity" userIsOnlineTimeWindow="15" hashAlgorithmType="">
    <providers>
        <clear />
        <add name="Public"
             connectionStringName="DefaultConnection"
             type="Telerik.DataAccess.AspnetProviders.TelerikMembershipProvider, Telerik.DataAccess" enablePasswordRetrieval="false"
             enablePasswordReset="true"
             requiresQuestionAndAnswer="false"
             applicationName="/"
             requiresUniqueEmail="false"
             passwordFormat="Hashed"
             maxInvalidPasswordAttempts="5"
             passwordAttemptWindow="10"
             passwordStrengthRegularExpression=""
             minRequiredPasswordLength="1"
             minRequiredNonalphanumericCharacters="0" />
        <add name="Sitefinity" 
             type="Telerik.Security.ActiveDirectory.TelerikADMembershipProvider, Telerik.Security" 
             connectionStringName="IowaDomain"
             enableSearchMethods="true"
             attributeMapUsername="sAMAccountName"
             connectionUsername="******"
             connectionPassword="******" />
    </providers>
</membership>

The configuration appears correct (and if I replace that provider with a dummy provider that simply logs calls and returns correct data I can see that the provider's methods are being called), but after logging in all requests time out. I can see that the timed out request is correctly authenticated -- it appears in the event log as authenticated with the proper credentials -- but no request ever comes back.

Looking through the Sitefinity forums and around via Google I don't see any issues of this type reported.

FYI - I have also verified that I can connect to the DB using the supplied credentials for it (which I've omitted above).

EDIT: Update -- same problem if I disable the Public providers. The Sitefinity providers are still the default.

Any ideas?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Setting the httpRuntime parameter executionTimeout to a larger value (600) seems to have solved the timeout issue. Now I need to figure out why it's taking so long.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.