Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

Our new organization thought it would be a good move to use Google Apps from the start.

It turns out that one of the features, Google Groups for Business, does not work.

May it be with or without multiple sign-in, when I click on "Groups", I get the following message:

You also belong to groups in 2 other organizations. hide
View 1 group at googleproductforums.com
View 1 group at myorganization.com

Clicking on the first link brings me to the Google Apps help group, and that works. However, I cannot access any of the groups I am part of in my own organization (although I created those groups from the Admin console). The error message I get is the following:

The page you requested is invalid. 

I tried using Chrome instead of Firefox, with only one user logged in, and it still does not work.

People have posted about the issue on the Google Apps Groups, and no one (not even at Google) has yet to answer, cf this post and that one, amongst a bunch I suppose.

Any idea on how to correct this issue? Thanks.

P.S.: I am the owner of the organization, creator of the Google Apps account, so I shouldn't have any limitation to the organizational groups I create.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Source of problem

Google Apps Groups is a bit confusing (for me at least).

Upon creation of a Google Apps account, groups can be created and emailed, but "Groups for Business" is not actually turned on. This is why the "request is invalid."

Turning on Groups for Business

To turn Google Groups for Business on, go to http://support.google.com/a/bin/answer.py?hl=en&answer=167096 and follow paragraph Enable Google Groups for Business. Note that it takes a few minutes for the SaaS to be activated (and may take up to 24 hours for everyone in the organization to activate it).

Configuration

Make sure to check how your groups are configured after switching. To do so, click on "Manage group settings" from the Admin console / Groups for Business / _GROUP_NAME_. Then go to "General settings" on the bottom of the left panel. From there you can reset the settings to a collaborative inbox, Q&A, etc. Then go into "Permission settings", that will allow you to choose who can post to this group.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.