Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I've set up filter in Gmail to label all mails/chats/hangouts with my wife. Filter is quite simple:

  • from:her-email-address@gmail.com
  • set label "Wife"
  • never send to spam

But now every chat/hangout message goes to main Inbox, not only to “Chat” folder (it is not archived—I don't want this). When I apply “skip the inbox” command, both chats and mails go directly to “Wife” directory and then my Android phone doesn't inform me about new mail. This is quite annoying. Is there a way to solve this situation and split mail and chat filters?

share|improve this question
    
Are you suggesting that your hangout messages used to be archived automatically? I don't recall that I have ever been able to archive these hangout messages - but I would like to very much! webapps.stackexchange.com/questions/47431/… –  w3d Aug 2 '13 at 20:02
1  
I'm not suggesting that they used to be, I'm saying they are archived automatically (both from my wife and other users) when filters are not active. Maybe my situation is different because I use Google account with my own domain? New features (and bugs ;) ) are implemented later then in 'open' accounts. –  Grzegorz Aug 6 '13 at 19:08
    
Thanks for confirmation. My question would seem to be very similar, except I'm on plain old Gmail and do not currently have any filters affecting this "hangout" user, yet still my hangout messages do not appear to get archived without me manually doing so!? –  w3d Aug 6 '13 at 19:56
1  
I made some tests. First I had created new Gmail accound (@gmail.com, not own domain) and then used to 'talk' with me (two separated computers in one network). On both accounts Hangout messages go directly to 'chat' folder, they are archived automatically without filters. –  Grzegorz Aug 6 '13 at 20:45
1  
Yes! It does auto-archive afterall; providing you don't have any filters set on that user. Thanks for that. I had previously deleted a filter on this user (very similar to yours as it happens), but it appears to have taken a bit of time for it to take effect. (AFAIK you can't (reliably) set filters on labels - so says the warning dialog if you try to do so.) Sorry, this doesn't really help you unfortunately - it just confirms your problem - if you have a filter on a user then hangouts from that user aren't archived!? Weird. –  w3d Aug 7 '13 at 10:38
show 2 more comments

3 Answers 3

You can match Chat or Hangout history messages with is:chat.

The opposite works too:

from:person -is:chat

Thus, you need:

  • from:her-email-address@gmail.com -is:chat
  • set label "Wife"
  • never send to spam
share|improve this answer
1  
Warning message seen when you create filter based on labels: Filter searches containing "label:", "in:", "is:", or stars criteria (i.e. "has:yellow-star") are not recommended as they will never match incoming mail. This filter doesn't work. We (I and @w3d) have tested this possibility. –  Grzegorz Aug 17 '13 at 8:12
add comment

I had the same problem, and found this Q&A. When I went to run some tests, I discovered that Gmail had added a checkbox for just this issue called "Don't include chats" (see screenshot of Search Options drop-down menu). I've been using this for almost a week and it seems to work.

enter image description here

share|improve this answer
add comment

Not sure if I understood your problem correctly, but if you want these chats to be archived and not showing in your inbox, you should use "Skip inbox (archive it)" option when creating a filter.

So your filter should be something like this:

from:her-email-address@gmail.com
Skip the Inbox (Archive it)
Apply the label: Wife
Never send it to Spam
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.