Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I'm trying to get the data from http://wodindex.wikispaces.com/ into my spreadsheets. Also from a different subdomain of wikispaces.com the grabbing doesn't work.

Trying to get data from this site gives me a #value error, while the same formula used with another URL (Wikipedia) does work.

What causes this error? Is this site somehow protected?

MWE: =ImportHTML("http://wodindex.wikispaces.com/";"list";1)

share|improve this question
add comment

2 Answers 2

up vote 0 down vote accepted

It seems wodindex.wikispaces.com attempts to store a cookie, and then do some fancy redirect tricks, for reasons I don't know. The functionality behind ImportHTML needs to work as a browser (or at least an HTTP client), and probably does not support cookies.

This is what I get from running wget http://wodindex.wikispaces.com:

--12:41:12--  http://wodindex.wikispaces.com/
           => `index.html'
Resolving wodindex.wikispaces.com... done.
Connecting to wodindex.wikispaces.com[75.126.104.177]:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://session.wikispaces.com/1/auth/auth?authToken=f7a1a3abdd9511c29392cf7000b27dd5 [fol
lowing]
--12:41:13--  https://session.wikispaces.com/1/auth/auth?authToken=f7a1a3abdd9511c29392cf7000b27dd5
           => `auth@authToken=f7a1a3abdd9511c29392cf7000b27dd5'
Resolving session.wikispaces.com... done.
Connecting to session.wikispaces.com[208.43.192.33]:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://wodindex.wikispaces.com/?responseToken=f7a1a3abdd9511c29392cf7000b27dd5 [following]

--12:41:14--  http://wodindex.wikispaces.com/?responseToken=f7a1a3abdd9511c29392cf7000b27dd5
           => `index.html@responseToken=f7a1a3abdd9511c29392cf7000b27dd5'
Connecting to wodindex.wikispaces.com[75.126.104.177]:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://wodindex.wikispaces.com/ [following]
http://wodindex.wikispaces.com/: Redirection cycle detected.

C:\Users\viramd>wget http://wodindex.wikispaces.com/
--12:42:28--  http://wodindex.wikispaces.com/
           => `index.html'
Resolving wodindex.wikispaces.com... done.
Connecting to wodindex.wikispaces.com[75.126.104.177]:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://session.wikispaces.com/1/auth/auth?authToken=2141639d8901c291dc288a940c9609e8 [fol
lowing]
--12:42:28--  https://session.wikispaces.com/1/auth/auth?authToken=2141639d8901c291dc288a940c9609e8
           => `auth@authToken=2141639d8901c291dc288a940c9609e8'
Resolving session.wikispaces.com... done.
Connecting to session.wikispaces.com[208.43.192.33]:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://wodindex.wikispaces.com/?responseToken=2141639d8901c291dc288a940c9609e8 [following]

--12:42:29--  http://wodindex.wikispaces.com/?responseToken=2141639d8901c291dc288a940c9609e8
           => `index.html@responseToken=2141639d8901c291dc288a940c9609e8'
Connecting to wodindex.wikispaces.com[75.126.104.177]:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://wodindex.wikispaces.com/ [following]
http://wodindex.wikispaces.com/: Redirection cycle detected.

As can be seen here, the request is redirected to session.wikispaces.com, which has some kind of redirect loop, that can never end.

One 'solution' to your problem is to save the contents of wodindex.wikispaces.com to another web server, and fetch it from there. But I'm not sure that would be entirely legal.

share|improve this answer
add comment

I've tried to reproduce your findings and was successful at it !!

The only logical conclusion I can think off, is that the site doesn't use the following tags:

LIST:

  • <UL>
  • <OL>
  • <DL>

TABLE:

  • <TABLE>
share|improve this answer
    
Thanks for your answer Jacob, I've rechecked the source, and it's all there: [ <table> <tbody> <tr> <th>Tags</th> <td style="white-space: normal;"> ...] Someone reported he couldn't access the source of the site from a mobile device; is it some kind of security issue with the site? –  Gauwain Aug 14 '13 at 13:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.