Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

For reasons I can't fathom, my Google searches keep ending up at http://www.google.com/webhp?hl=chr. What language is 'chr' (I don't why I can't find this by searching Google, but I can't)? More importantly, how do I stop it?

(Note: going to 'settings' and setting my language to 'English' was not effective.)

Edit: It's a bug in Firefox.

share|improve this question
    
What happens if you delete the webhp?hl=chr part? –  Alex Aug 1 '10 at 17:02
1  
That's a beautiful looking language... –  defrex Aug 1 '10 at 19:00
add comment

4 Answers

up vote 10 down vote accepted

Whoa, those are crazy letters! I think Alex is right about the Cherokee language.

Use google.com/ncr to force the English interface. ("ncr" means "No Country/Culture Redirect.")

If you want to force your browser's homepage to show Google in English, you will have to set your homepage to google.com/ncr in your browser's settings.

Edit: Google probably determines which default UI language to show based on your IP address. Your IP address probably geo-locates to a place where Cherokee is used by most of the people. For example, I am located in Korea, and I always get the Korean version of Google. However, if I set the Google settings to use the English UI, it uses English for that computer/browser. This requires browser cookies; do you have cookies enabled?

Also, if your browser explicitly sets your homepage to http://www.google.com/webhp?hl=chr then Google will dutifully display Cherokee.

share|improve this answer
    
The redirect fix is unsatisfactory. Why does it keep redirecting me there? I've changed Google's settings to english. Changing the browser to use google.com/ncr (it just uses Google) is a nasty nasty fix for the problem. –  Paul Biggar Aug 2 '10 at 21:54
    
I'm sorry, but there is no place where Cherokee is used by most of the people. The geo-location theory must be incorrect. –  nohat Sep 30 '10 at 20:27
    
Browsers usually have a list of preferred languages. Google considers both that and the IP geolocation, or at least it did use each of them at various points in history. –  configurator Sep 30 '10 at 20:40
add comment

It's the Cherokee language & alphabet: http://www.native-languages.org/cherokee_alphabet.htm

share|improve this answer
add comment

I had this too, and discovered this in my Firefox language settings:

alt text

Firefox must be seeing "chrome" and reading "chr" = cherokee. Removing that line fixed the problem.

I've recently turned on Firefox sync, Xmarks (installed in both Firefox and Chrome) and Chrome sync, so I suspect one of them has done this by mistake. Funny!

share|improve this answer
    
I use firefox sync, so that might be the culprit. –  Paul Biggar Sep 30 '10 at 20:43
    
Yes, I think you must be right - Firefox sync is trying to sync the language preferences. But where is it getting 'chrome...properties' from? –  tim_hutton Sep 30 '10 at 21:28
    
Yes Tim! The Chrome thing was the problem. I guess the problem was using Xmarks with all browsers together at first, then switching to FireFox Sync. The FireFox Sync add-on saves and misinterprets the Google Chrome settings leading to this funny problem. Another question: did you all use Windows or Linux based platforms? I got this problem just with Ubuntu. Cheers Frank –  Frank Abel Oct 13 '10 at 5:42
    
Well, chrome is the name for files and resources within firefox, but I don't know how it got like that. –  Paul Biggar Oct 13 '10 at 14:49
1  
See bugzilla.mozilla.org/show_bug.cgi?id=580833 for the bug report. –  Paul Biggar Oct 13 '10 at 14:50
show 1 more comment

Just follow this detailed tutorial on making Google your Homepage .If it doesn't work replace google.com with google.com/ncr ,that must work.

share|improve this answer
1  
That suggestion was already given by the answer, marked as best. –  Jacob Jan Tuinstra Jun 7 '13 at 20:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.