Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I'm running Chrome on my Mac and all of the sudden videos started playing in the HTML 5 player instead of the Flash player.

I am not in the HTML 5 trial, the button says Join instead of Leave and I have tried joining and leaving to try and toggle something but that hasn't worked. I have even tried adding &html5=false to the end of the url and not even that has seemed to work.

Has anyone got any idea on how to switch it back to the flash player? Thanks!

share|improve this question
    
What indicates that the videos are playing in HTML5? –  Vidar S. Ramdal Oct 22 '13 at 7:32
2  
Upon right clicking the video, it displays the HTML 5 menu with one of the options being "About HTML 5" –  SteppingHat Oct 22 '13 at 7:50
2  
Even worse, HTML5 elements are not affected by Chrome’s click-to-play function, so there is no way to prevent Youtube videos from automatically loading, buffering, and playing. There are some extensions that can help with this, but they don’t work with Youtube’s Feather mode. ಠ╭╮ಠ –  Synetech Nov 22 '13 at 20:00
2  
Here's how I enforced my dominion over Chrome: Find the file called ffmpegsumo.dll where Chrome is installed (C:\Program Files (x86)\Google\Chrome\Application\30.xxxxx\ for me). Delete it or move it out of that folder. I also moved nacl_irt_*.nexe. –  Wayne Bloss Nov 27 '13 at 21:28
    
@wizlb Where would the file be located on Mac? –  SteppingHat Dec 3 '13 at 1:07

4 Answers 4

You can use the YouTube Options extension for Chrome:

enter image description here


Update (2014-04-12): the YouTube Options extension for Chrome now costs $2:

"YouTube Options" cost $2.00 per month, below is a copy of the user agreement one has to confirm prior to using it.

This extension is based on a paid subscription model. It costs a flat fee of $1.99 per month, with half of all proceeds going to non-profit organizations. Why the monthly fee? YTO is a fully supported, ever-evolving product and half of the subscription fee goes toward sustaining the level of effort needed to develop quality software. But we’re not just trying to make our product better — we’re trying to make the world better, too. The other half of the subscription fee is donated to causes we believe in. Visit the SPOI site to learn about the charities we are supporting this year. For more information on the ways you can customize your YouTube experience, explore the options here, or get the full list of more than 120 configuration options on the YouTube Options site. Until you purchase a subscription license using PayPal, YouTube Option’s functionality will be disabled.

Which means I won't use it anymore.

share|improve this answer
2  
How about github.com/YePpHa/YouTubeCenter/wiki ? –  Franck Dernoncourt Oct 26 '13 at 17:03

I found a solution here: https://groups.google.com/forum/#!topic/mozilla.dev.extensions/0ZgKDAFfUDc

Here's how I disabled HTML5 video in Chrome on Windows: Find the file called ffmpegsumo.dll where Chrome is installed (C:\Program Files (x86)\Google\Chrome\Application\30.xxxxx\ for me)

Worked for me as well, but after a while the html5 player returned. Maybe we will have to remove this file each time Chrome is updated.

share|improve this answer

Finally found a fix! So simple I wonder why I never thought of it in the first place..

Simply deleting all the cookies that youtube.com has saved switched me back to the flash player.

My best guess is that when it came time to opt-out from the HTML5 trial the cookie was never properly cleared or set back to flash.

share|improve this answer
    
It's just reverted back to HTML5 again and a cookie clear won't do anything anymore -.- –  SteppingHat Jan 15 at 1:52

If you're using Chrome on OSX, Go to the Application folder, right click on "Google Chrome" click on "Show Package Contents" then navigate to Contents/Versions/{version-number}/Google Chrome Framework.framework/Libraries.

Then rename or delete the .so file that contains ffmpeg in the name. Restart Chrome

If your using Chrome on Windows 8: Navigate to Program Files/Google/Chrome/Application/{version-number}/ and rename or delete ffmpegsumo.dll

Restart Chrome

After completing the above if you right click on a youtube video you'll see that it uses the flash player version.

The only issue with the above is that whenever Chrome has an update the ffmpeg file will be restored, so you'll need to repeat the above steps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.