Sign up ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I want to create a filter for all email sent by me only to me.

I do that because when I have a note that I want to remember, I send it to myself. I want to label all those notes so I can find them easily.

share|improve this question

5 Answers 5

up vote 11 down vote accepted

To search for email sent only to you and not to a mailing list, for example, you have to add the following to the search box (and then you can create a filter using that search; there is a link in the expanded search box that says "Create filter >>" or something):

To:me AND -*

This means it'll search for email sent to "me" (that's you) and not to everybody else (including you) (that's "*"), but the first part (i.e., "To:me") overrides that.

share|improve this answer
Ain't working no more? –  nutty about natty Aug 23 '14 at 9:33

When creating the filter, can you put your email address in the from field and in the to field. I just tried this and it only includes emails that I've sent to myself.

Here is some of the help on Gmail's search (somewhat unrelated):

share|improve this answer

In the To field, use me -*. This could also be broken out in the other fields with to:me to:-*.

Here's a thread on Google's help forum..

share|improve this answer
Do you have a link to documentation of this feature by any chance? –  Senseful Aug 2 '10 at 22:58
@Senseful, Unfortunately I don't. It is just something I tried. I did some searching and found a link that is somewhat helpful. Edited my post to include it. –  Rebecca Chernoff Aug 2 '10 at 23:32
I get the to:me part, but it doesn't seem like the -* part does anything (i.e. I get the same results with and without it). Does it show different results for you? –  Senseful Aug 2 '10 at 23:40
I believe the second example should be to:me -to:*. However, the search doesn't seem to exclude messages sent to a list of addresses. –  dgw Aug 3 '10 at 0:02
to:me to:-* and to:me -to:* seem to give me the same results. –  Rebecca Chernoff Aug 3 '10 at 0:10

Try replacing -* with a couple of common email addresses in the heavy emailers list. something like this might work to:(me -*

share|improve this answer

This new answer works if one of the other recipients has a top level domain that is common-ish and different from yours.

Aaron's answer appears not to work, for two reasons. The first is that google does not implement wild cards in gmail (Wildcard search in Gmail). The second reason is that, from experience, I find the search considers BOTH conjuncts, to:me and, say, -to:com. It's easy to check by entering to:me -to:com in the search bar, and finding that nothing sent to your address is there.

From the question I linked above we know that you need to search tokens; e.g., top level domains like .com and .org. But we know we can't just do

to:me to:(-com -org -edu -gov -uk -net -ca -de -jp -fr -au -us -ru -ch -it -nl -se -no -es -mil)

As an aside, don't try and putting ALL top level domains in, as the search will be rejected for length. I got the above list from This blog post about common TLDs.

There is one more thing to deal with, and that is the empty to: field. My work around is to use is:important to limit the intrusion of these. Gmail complained when I tried to make a filter with this flag, but it did properly filter a new (important) email to me.

So, we come to my answer, where my own top level domains are .com and .uk (, but the .uk is a token in itself):

is:important to:((-com OR me) -coop -org -edu -gov (-uk OR me) -net -ca -de -jp -fr -au -us -ru -ch -it -nl -se -no -es -mil)

This enforces the following two properties: 1. Emails to anyone with a listed domain different from yours are rejected 2. If an email has one of your domains, it must be (at least) to you.

In a similar manner, you can add specific email addresses that you commonly receive email together with you by adding something like -<>

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.