Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Blogger real-time stats was just recently introduced. How can I exclude my own visits from counting in these statistics?

I know it is possible to set a cookie to exclude self traffic in Google Analytics. Is something similar possible with Blogger real-time stats?

share|improve this question
dont visit :P ;) – Ayush Goyal Oct 27 '10 at 1:21

Sweet! Blogger in Draft just implemented a feature to exclude your own visits. It does not seam to work, yet, though.

Update: This cookie does not seem to hold it's value and work in IE (8). I realize it is just a "draft" feature, but I'm considering using the HOSTS file instead.

Update 2: Even when the cookie maintains it's value in non-IE browsers, the visits are still tracked. This new "draft" feature still has some kinks...

There is a new "Don't track your own pageviews" link in the real-time stats tab:

alt text

share|improve this answer

Block the Google Analytics domain from your HOSTS file:

# [Google Inc] www.google-analytics.com ssl.google-analytics.com

Apparently this might break some sites...


update: Blogger doesn't seem to use these URL's... anyone know the right URL to block?

share|improve this answer

I have been playing around with the Blogger stats and the "Don't track your own pageviews" option. Using an obscure blog of mine which gets 0 traffic, I noticed that every refresh resulted in a +1 in the stats page.
After many experiments and fiddling around, I noticed that my blog redirects to a country-specific url (.co.il, in my case). I tried navigating to the .com url (Using the /ncr option, as specified here), and finally got it to work - refreshing the .co.il tab adds 1 to my stats, refreshing the .com tab does not.
Seems like a bug on Google's side. I hope they will get it fixed.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.