Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

Question

I have Google Docs open in the Google Chrome browser on a Mac. Now I select a piece of text and want to change it's font just with keyboard shortcuts -- without using the mouse.

Example before font change:

enter image description here

Example after font change to e.g. Courier New:

enter image description here

How do I do that?

What I have tried so far

I've read the Keyboard shortcuts for Google documents page, but haven't found anything useful.

There is the Ctrl+Shift+F keyboard shortcut to collaps the menu bar, which then displays the Search the menus (Alt+/) search box.

Menu before pressing Ctrl+Shift+F:

enter image description here

Menu after pressing Ctrl+Shift+F:

enter image description here

Now this search box is pretty awesome because I can just type "Courier New" and hit Enter. But! Alt+/ is not working! Why not? I can't get the focus into that search box.

At this point, I should perhaps note that the keyboard layout is set to German.

The US keyboard layout looks like this:

enter image description here

The German keyboard layout looks like this:

enter image description here

So the forward slash / is on the 7 key: Shift+7.

But when I press Alt+Shift+7, it opens the Mac OS X Help > Search menu:

enter image description here

I also switched to the US keyboard layout. But pressing Alt+Shift+7 (which is the key left of the right Shift key) produces the same effect.

I've also tried the forward slash key on the number block. No success.

Plus, I've tried Option+/ as documented on the Keyboard shortcuts for Google documents page (the Option key is the Alt key according to Wikipedia). No success either.

enter image description here

Is Mac OS X highjacking the keyboard shortcut?

Versions

  • Google Chrome 31.0.1650.63
  • Mac OS X 10.9.1
share|improve this question

3 Answers 3

Works for me on windows - I would suggest that OS X is hijacking the shortcut. You could possibly try overriding the Keyboard system preferences (I think it's in: System Preferences | Keyboard | Keyboard Shortcuts).

This search had some useful links.

share|improve this answer
    
Thank you for testing it on Windows and confirming that it works there. I tried your suggestion and disabled the shortcut in System Preferences, but unfortunately it didn't work. However, your suggestion inspired me to try a few more things which led to finding a workaround. Thank you! –  Lernkurve Dec 27 '13 at 15:03
up vote 1 down vote accepted

I found a workaround.

  1. Select a piece of text in the document.
  2. Ctrl+Alt+H opens the Help menu.
  3. Arrow down puts the focus in the Search all menus menu.
  4. Type "cour", hit Enter.

enter image description here

share|improve this answer

Not sure exactly what your use case is, but if your goal is to quickly apply a font repeatedly, the easiest way is to first select a block of text with the font you want, hit Command+Option+C to copy formatting, then each time you select the text you want to apply the font to, just hit Command+Option+V to paste formatting.

Note: Doesn't work the first time, but it'll work each subsequent time.

share|improve this answer
    
"Doesn't work the first time, but it'll work each subsequent time" is strange, but correct. My use case is exactly what is described in the question. Which means your suggestion is not the best solution for me because I have to interrupt my workflow by looking for some other piece of text which is formatted the way I want to format the current piece of text. But thanks anyway! Your tip might come in handy in other situations. –  Lernkurve Jun 14 at 8:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.