Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I am forwarding my Google Voice number to my work number (cell phones are prohibited in the workplace). When someone calls my google voice number, my work voicemail system answers. I would prefer that Google Voice would handle the voicemails because the system at work is a huge pain. I haven't found any setting in Google Voice that would help. Any suggestions? Of course there is the way to schedule time, but my schedule varies from day to day.

I don't know if this would be the right place to ask this but here goes: As a solution to this problem, I was thinking that somehow Google voice would know to which phone to forward based on the location of my mobile device. It is a long shot, but has anyone heard of this?

The best solution for me would be always forward to all phones and google voice would always answer for the voicemail.

share|improve this question
    
Google Voice picks up after 30 seconds, so if your work phone system picks up before then, Google Voice considers it answered. That leaves you with the unenviable task of getting IT to increase the number of rings before going to voicemail. –  Al E. Aug 16 '10 at 21:21
add comment

5 Answers 5

Your work system is probably picking up before Google Voice times out and handles the voicemail. The usual suggestion for cellular and home phones is to record a lengthy voicemail greeting on the problematic line so the beep doesn't sound before Google Voice hangs up and reroutes the call to its own VM system. However, your mileage with that solution on a work system may vary.

share|improve this answer
add comment

Changing Google Voice settings based on GPS has been done. Check out this article from Lifehacker.

It's not a trivial effort, though.

share|improve this answer
add comment

Turn on Call Screening

I had a similar problem with forwarding to my skype-in number. Since you can't change the delay before voicemail for either of them, I enabled the Call Screening option. When a phone picks up, google asks you to press 1 to take the call. Since your work voicemail doesn't press 1, Google keeps ringing all other phones until the 30 seconds are up.

share|improve this answer
    
Get this. On one of my phones the number 1 doesn't work. I've been using google voice to dial out on that one. Time to get a new phone it seems. –  SaulBack Aug 17 '10 at 13:30
    
@saulback you can hit 2, it send them to voice mail, but then you push * to join the call. You can here the person leaving you a message, and just join the call immediately. at least until you get a new phon, –  Larry Dec 8 '10 at 23:53
add comment
up vote 0 down vote accepted

Google Voice Locations is now in the app market. It's in beta but it's working perfectly for my needs.

share|improve this answer
add comment

Instead of forwarding to your office phone, you can forward to Google talk. It's a VOIP solution. If you sit in front of a computer at your desk you can just have voice, or gmail open and answer with your computer.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.