Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I have a family domain set up with Google Apps Standard. Everybody has their own calendar, and then a shared family calendar.

I configured my daughter's iPod Touch to talk to GMail using the Google Sync (= Exchange) mechanism.

The shared calendar doesn't show up.

Google's help page claims that, if I go to m.google.com, select the domain, and log in, I can select Sync and configure the calendars. I don't see any such option on the touch. When I select sync from the green region, all I get is a link to a help page, and, on that help page, I get the string 'null' where I should get the string 'ipod touch'.

Ironically, if I just use the safari access to the calendar, I do see the entries from all of the calendars.

Is there something Google isn't telling me, or have I just hit a bug?

share|improve this question
    
I am having the same issue with Google Sync and an iPod Touch. The issue of "null" where it should say "ipod toch" Any suggestions on where to look? –  Lupe Silva Sep 6 '10 at 16:57
add comment

1 Answer

up vote 1 down vote accepted

You need to first make sure that the Google mobile service is enabled in the Google Apps dashboard. If it isn't, add the Mobile service, and make sure that the Enable Google Sync is checked.

Next, you navigate to m.google.com on your mobile device. Enter in your domain (like you said), and tap the green Sync. This should take you to a page which has the "How to setup Google Sync on X" link you mention. Do not click on that link. Instead, click below it where it says "Sign in with your Google Apps Account" (it's easy to miss since it looks like a footer). Once you sign in, you should see your device listed there (for me it says iPhone). Tap it and you should be able to select which calendars to sync.

I tested this on both an iPhone and iPad, not an iPod touch, however it's very unlikely that it wouldn't work. In the rare case that it still doesn't work, I would recommend using a desktop browser and spoofing your user agent as the iPhone. Safari has this feature (along with the iPhone's user agent) built into it. Just select Develop > User Agent > Mobile Safari X.X -- iPhone. You should then be able to navigate to m.google.com and follow the same steps above.

share|improve this answer
    
Been there, done that. (first two paragraphs). I guess the third is my next option. –  bmargulies Sep 11 '10 at 23:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.