Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I'm composing HTML for a text post, and find that whenever I use the <cite> tag, it disappears when I preview the post or switch to rich text mode. Other tags, like <sup>, don't have this problem (even if I have to use custom CSS to make them do the right thing). Why does this happen and is there anything I can do about it?

share|improve this question

2 Answers 2

This probably happens because <cite> is a custom HTML tag, while <sup> is a tag that was recognized by Tumblr. And Tumblr probably filters out all HTML tags it doesn't know, for security reasons. So whenever you switch view, Tumblr starts filtering out these parts of your text.

I would suggest you use <span class='cite'>CITATION</span> instead of <cite>CITATION</cite> in your HTML code; and .cite instead of cite in your CSS code. Spans are normally HTML tags that are recognized by almost all browsers and web applications.

Footnote: I haven't tested it, because I don't actually use Tumblr myself. But I do have a strong feeling this will probably solve your problem.

share|improve this answer

It happens because <cite> is on an unpublished list of tags that are automatically removed.

To fully control the HTML that appears on a text post, you'll need to change your Text Editor settings to Plain text/HTML

You can set it here:

Settings (Gear icon) → Dashboard (on sidebar)

After that you would be able to use HTML tags like <cite> or what have you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.