Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

SMTP on gmail.com works just fine for one address, but fails for another valid address. These settings work fine:

Email Server: smtp.gmail.com
Email Port: 587
Email User: myaddress@gmail.com 
Email Password: mypassword
Use TLS: True

However, if I substitute in a different address - okfn.wdmmg@gmail.com and its password - then I can't connect to SMTP.

I am CERTAIN this address and password are OK, I can log into Gmail with them. POP is enabled for the address.

Any ideas why Gmail SMTP might be objecting? Thanks!

share|improve this question

closed as too localized by Sathya Apr 9 '13 at 3:46

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
What email program are you using for this? –  JNK Sep 8 '10 at 13:52
    
I'm actually using OSQA: I've asked the same question over here: meta.osqa.net/questions/4729/… - they reckon it's a Gmail problem. –  AP257 Sep 8 '10 at 13:55
    
What application are you trying to set this up in ? –  Chris Oct 8 '10 at 17:52
    
Try setting your account with IMAP Enabled it may solve your problem not totally sure, but do try that. –  Dhruvenkumar Shah Sep 28 '12 at 5:07
add comment

3 Answers 3

Change:

Email Port: 587

To:

Email Port: 465
share|improve this answer
add comment

Try using some other mail client with the same credentials so that you can know for sure if it's a problem with Gmail or OSQA.

Also, try to use the original name you chose for the Gmail account in regards to where the dot is in the name. For example, if you created the account as oxfn.wdmmg@gmail.com, use that as opposed to o.xf.n.w.dm.mg@gmail.com (even though both point to the same address).

share|improve this answer
    
I can connect to OSX Mail with the login credentials, and send mails just fine. Does that imply that it's an issue with OSQA? –  AP257 Sep 8 '10 at 16:17
    
As long as you are sure you setup both mail clients exactly the same, then yes, that would mean that it's a problem with OSQA, since you just proved that it works with another mail client. –  Senseful Sep 8 '10 at 16:36
    
unless OSX Mail is using IMAP... any idea how I can check? –  AP257 Sep 8 '10 at 18:18
    
@AP256: One option is to disable IMAP in Gmail temporarily. Another is to right-click your account in Mail.app and choose to edit it. You should see something like "Gmail IMAP" or "IMAP" under the account name. Regardless of if it is using IMAP or not, though, SMTP is for outgoing messages, both POP and IMAP use SMTP for outgoing messages, so it shouldn't matter if it is using it or not. You can change the SMTP settings by finding the "Outgoing Mail Server (SMTP)" setting and choosing "Edit SMTP Server List". –  Senseful Sep 8 '10 at 19:22
add comment

Try to login with just okfn@gmail.com or okfnwdmmg@gmail.com . I think the dot is ignored in the username.

share|improve this answer
    
doesn't help, alas. thanks anyway. –  AP257 Sep 8 '10 at 18:23
    
dot is ignored in username, you can send mail to a.b.c@gmail.com or abc@gmail.com. As well as login using abc@gmail.com or a.b.c@gmail.com –  Chris Oct 8 '10 at 17:52
add comment