Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

There used to be an option for turning Google Suggest off permanently, but since Google Instant was launched it appears to be gone. A temporary solution is to open

http://www.google.com/search?complete=0

but this doesn't save the option. I would like the option to be permanently saved in my cookies.

share|improve this question

6 Answers 6

Change search engines to one that doesn't use auto complete and suggest. ixquick is one. most of the others have followed Google and screwed the pooch by forcing cookies instead of a permanent opt out. Or you can rewrite and dismantle parts of the search engine piece by piece or build your own search engine without it. That leaves Noscript and Greasemonky to block it.

Of course doing so you can accidentally so completely disable the engine knocking out updates that bypass everything you've done every 3-6 months that you end up making the search engine unusable. Forcing you to find another one.

Best choice? Abandon the forced use of Auto Complete/suggest engines and migrate to those few that don't use it or have a permanent opt out that doesn't require a tracking "Cookie".

share|improve this answer

In IE8. Go to Manage Add On. Select search providers. Select Google. Next to the search suggestions either select Enable or Disable to turn suggestions on or off. Close.

share|improve this answer
    
Do you understand what this setting does behind the curtains? Does it block a certain javascript, or maybe write an undocumented value to a google cookie or is there some kind of other noticable behaviour? –  Stefan Schmidt Aug 1 '12 at 18:50

Google Suggest is being replaced with Google Instant. With Instant you can turn off Instant but not auto complete.

To turn instant off go to google.com:

  • Click the "Setting" link at the top right and select "Search Settings"
  • Scroll down to the "Google Instant" section and select "Do not use Google Instant"
  • Click the "Save Preferences" button

You can use http://www.google.com/search?complete=0 to turn off the auto complete but it is not permanent.

share|improve this answer

There is an option in 'search settings' panel to disable Google Instant, you can check this Google Instant Brief Guide.

share|improve this answer

Google Suggest is being gradually replaced with Google Instant in various parts of the world. At any rate, do the following:

  1. Go to Google.com (or your local version, or iGoogle) from any browser.
  2. Click the "Setting" link at the top right and select "Search Settings"
  3. Scroll down to the "Autocomplete" section and select "Do not provide query predictions in the search box."
  4. Click the "Save Preferences" button

You may have to repeat between browsers, as I believe the search preferences are saved to a cookie.

Update: since writing this, Google has change the settings page and now mine looks like this: Gogole Autocomplete Settings

However, if you go to the Google SSL site (https://www.google.com) and select "search settings there, you'll see this option: Google SSL Settings

IMHO, if you turn these off and STILL get suggestions/instant - it's a bug that should be reported to Google (and remember, Instant was just launched a week ago, so give them time to fix their bugs).

share|improve this answer
    
I don't see the Autocomplete section. –  Senseful Sep 15 '10 at 16:46
    
Really? I've had one for years. It just changed from "suggest" to "instant" last week. Also, try accessing your dashboard (google.com/dashboard - login required) and clean your "web history" –  Traveling Tech Guy Sep 15 '10 at 17:34
    
Even if you turn "instant" off then "suggest" is still active! –  Stefan Schmidt Sep 15 '10 at 21:41
    
@Stefan Please see my latest edits. –  Traveling Tech Guy Sep 16 '10 at 8:44
    
Turning off Autocomplete on the SSL page works fine. I tried copying the relevant parameter of the preferences cookie to the non-SSL page but unfortunately that didn't work. I guess that would have been too simple. I guess it's a matter of days or maybe weeks until they migrate the SSL page to Google Instant. –  Stefan Schmidt Sep 16 '10 at 15:14

The closest I've found is this Google support page on turning off autocomplete in the address bar when using Chrome:

In the "Privacy" section of the "Options" dialog, deselect the "Use a suggestion service to help complete searches and URLs typed in the address bar" checkbox.

The only other thing I've found on this topic is here:

To disable history-based search customizations while signed in, you'll need to remove Web History from your Google Account. You can also choose to remove individual items. Note that removing this service deletes all your old searches from Web History.

This will stop Google looking in your previous searches, but I don't know whether it will stop all of the autocomplete functionality.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.