Sign up ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

My inbox is being destroyed right now—I'm getting 3–4 messages a minute from a specific host ( for some reason. I would really like to just prevent any and all email from his host from even getting to my inbox.

I have created a filter in Gmail, the problem is that Thunderbird, which is setup via IMAP, is placing those messages in the trash. My trash is growing by 5 messages per minute.

It’s taking its toll on Thunderbird, and my CPU usage.

Can't I just somehow prevent some known bad host, or domain, from getting into my inbox?

I don't want to “put these files in the trash”—that's just another folder in Gmail terms.

I want them to either A) be deleted not placed in a trash folder, or B) ideally never even get that far.

Is this possible?

share|improve this question
For what it's worth, I use Bluehost for my own hosting. I'm sure they would want to know that one their customers is spamming and that they would take care of it ASAP. Email them at with the details. – Al E. Sep 28 '10 at 13:19
Setting a filter for a domain the email is coming from only works when the spammer uses the same domain--not if the domain's name is being spoofed. – Chuck Menieres Aug 10 at 15:07

5 Answers 5

You can do that using a Filter.

Steps to follow:

  1. Go to setting page of GMail.
  2. Click on the Filters Tab.
  3. Click on "Create a new filter" buton.
  4. In the "From" field write "*" (without " " - if your mails are comming from addresses like,, etc...)
  5. Click on the "Next Step" button.
  6. Check the "Delete it" and "Also apply filter to ** conversations below" (here "**" is the email count) checkboxs and click "Create Filter"

All mails from that type of email address will be deleted (including messages in the Inbox) automatically.

share|improve this answer
But user4683 said: I don't want to - "put these files in the trash" - that's just another folder in gmail terms. – Lipis Oct 1 '10 at 8:53
It sounds like the OP already has this sort of filter set up. The problem is that Thunderbird is syncing his trash folder as well. – Senseful Oct 15 '10 at 23:32

From the web interface, select a few of these spammy mails & click the Report Spam button.

share|improve this answer
spam button doesn't work. i click on it and it keeps coming thru – jason yesterday

There is no way for you to do this directly, however you can indirectly make it happen by using the web interface to select a bunch of them and mark them as spam. Seriously after you select enough of them and mark them as spam consistently when they come in, they will get blocked upstream from your account. It's not an instant magic fix, you are going to have to wait for gmail to train itself on these messages.

In the mean time disable syncing the trash folder in your thunderbird / gmail imap settings so that you can survive the deluge. If you can't figure out how to actually disable the trash, filter them to a folder instead because it is much easier to not sync an imap folder. Just make sure you specify "skip the inbox" as well as the labeling for a folderin your filter. Then periodically open that folder from the web and mark everything as spam.

share|improve this answer

I haven't tried this, but it might work.

You can enable the LAB advanced imap controls and then under labels uncheck show in imap for the thrash label. You wouldn't get the online thrash folder available in Thunderbird and therefore not all the flooding mails.

How good this will work for you depends on how you have configured your Thunderbird alas if deleted emails in Thunderbird is sent to thrash or just archived

share|improve this answer

Gmail doesn't offer end users a way to block email messages, but you could set a filter to automatically process them, i.e. mark as spam, delete them, apply a label, as you already did.

Besides this you could set which labels will sync through IMAP with email client. So you could disable the SPAM, Trash or both labels for a while, until Google block those messages for you. To do so,

  1. Go to
  2. Click on Settings (cog wheel) > Settings > Labels
  3. Next to each label, click to put/remove tick marks on the related "Show in IMAP" checkbox.
share|improve this answer

protected by Community Aug 11 at 13:55

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.