Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

Please note that my computer's time is set correctly. Dates and times are correct in all other applications including Google's services such as Google Docs and Google Calendar.

However, messages in Gmail are always showing with a timestamp eight hours into the future. Occasionally, after repeated set/reset cycles in my account settings, I get the correct timestamp but when I log out and log back in timestamps are again eight hours into the future.

I have already inspected the email headers, and the timestamp information (including time zones) is correct at each hop.

There are a number of threads on Google's support forums regarding this and the one that is being monitored by the Google staff seems to be Wrong time posted on all my email - how to fix.

Is anyone aware of a fix or a work-around or at least an explanation of why the timestamps are messed up?

share|improve this question
2  
What's your timezone, and what's the timezone messages are being shown in? Does this happen with emails received from sources in all timezones? Does it happen with emails you send yourself? Have you set the right timezone in Gmail's settings? –  ShreevatsaR Oct 12 '10 at 3:18
    
@ShreevatsaR: Windows time zone: Eastern (GMT-05:00), Gmail time zone: Eastern (GMT-05:00) It happens with all emails I send myself as well. However, if I send a message from my GMail account to Yahoo!, Yahoo! displays the date/time correctly. Cleared all cookies (Google's .google.com and .mail.google.com had cookies called TZ with a value of 240. –  Sinan Ünür Oct 12 '10 at 12:00
    
The solution given doesn't work with my 2013 G-mail. My G-mail doesn't have 'accounts' under settings, so I can't use the given advice. Sorry. Does anyone have any ideas for those of us who have current versions (July 2013) of G'mail? Most of the free advice in these forums is over two years old and work for XP. Some of us have Win8. –  user43078 Jul 3 '13 at 4:25

4 Answers 4

up vote 5 down vote accepted

We have a standing FAQ in our organisation that if you see any sort of timezone-related issues in Gmail your should enable the "Sender Time Zone" lab, reload, then disable the lab again (unless you actually want it). This seems to reset Gmail's timezone handling. We haven't yet got to the root cause yet (despite much back and forth with Google support), but we find that this resolves timezone issues most of the time. Give it a try.

share|improve this answer
    
Unfortunately it looks like this feature has been retired from Labs now... –  yochannah Apr 4 at 11:07

I still had the problem with an incorrect time stamp in Gmail even after ensuring that the time zone information was set correctly in Windows XP, Gmail, and Google docs. However, after deleting the environment variable TZ, the problem disappeared for me.

share|improve this answer
    
Where/how did you do that? Can you provide a bit more of a guide to how you fixed the problem? –  Andrew Lott Jul 3 '13 at 7:06

You need to correct your Gmail time zone.

To set your Gmail time zone:

  • Follow the Settings link in Gmail.
  • Go to the Accounts tab.
  • Follow the Google Account Settings link under Other Google Account settings
  • Now follow the edit your personal info link under Email addresses.
  • Select the correct time zone under Time zone.

If you cannot find the correct city or time zone, try checking Show all timezones. Click Save.

share|improve this answer
1  
-1 For not checking the information you shared. The blurb you had was completely outdated and confusing. –  phwd Oct 16 '11 at 20:20

These are the steps I took:

  1. Click on the Start button (in the lower left corner of the desktop)
  2. Go to Control panel
  3. Click on Clock and select, Language and Region
  4. Click on Date and Time, then look at the time zone and see if it is correct. If it is, then there's no need to change it but if it isn't, then change it.

    In the same screen there's also a button that says: Change date and time. Both of these need to be set correctly. Then click save and your problem will be solved.

  5. When you go back to gmail... you must refresh the page to see that it has been fixed.
share|improve this answer
1  
The OP stated that both the timezones on gmail and his OS was set correctly. This doesn't answer his question. –  Dez Dec 14 '12 at 3:01
    

protected by Community Aug 15 '13 at 16:32

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.