Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

Possible Duplicate:
How to test google.com outside the US?

I live in Switzerland, and Google insists on speaking to me in German instead of English. I don't understand German. It's so frustrating. I'm logged in with my account and configured it here http://www.google.com/preferences to work en English every time I log in.

Still, for example, https://www.google.com/accounts/b/0/ManageAccount appears in german for me.

BTW, it's extremely frustrated that they don't just give the language I'm requesting, my whole machine works in English and my accept headers clearly list English as my preferred language.

share|improve this question

marked as duplicate by Senseful Oct 28 '10 at 8:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Possible duplicate - webapps.stackexchange.com/questions/7778/… –  ChrisF Oct 20 '10 at 11:36

2 Answers 2

Change your bookmarks, homepage etc to http://www.google.com/ncr This will ensure that it ignores the IP country detection. Ensure you delete all cookies etc first.

This should display everything in English.

Source Article

EDIT

What you can do is create a custom search within Chrome:

  • Go to "Options"
  • In the "Default Search" click "Manage"
  • Click "Add"
  • Enter the following details:
    • Name = GoogleCustomised
    • Keyword = google.com
    • URL = http://www.google.com/search?{google:RLZ}{google:acceptedSuggestion}{google:originalQueryForSuggestion}sourceid=chrome&ie={inputEncoding}&q=%s
  • Click OK
  • Then click GoogleCustomised and click "Make Default"

This should ensure that Google Chrome always uses www.google.com as the default search site. Which is in English.

Hope this helps

share|improve this answer
    
Good answer. Thanks for including the citation. –  Sam Oct 20 '10 at 13:00
    
I'm not using any bookmarks, I'm just searching in Chrome's url/search bar. –  J. Pablo Fernández Oct 21 '10 at 9:17
    
I have updated my answer. Thanks –  Barry Oct 21 '10 at 11:46
1  
this is a good answer, could you please add it as an answer to the other question? –  Senseful Oct 28 '10 at 8:18
    
@Senseful - Done as requested. Cheers –  Barry Oct 28 '10 at 16:21

For most google sites, adding ?hl=en to the URL always works for me whenever I get redirected to a page with a different language.

Another way to handle it is to add German as the secondary language for your browser.

share|improve this answer
    
Adding German as secondary language causes Google to respect English as my primary language? That would be weirdly awesome. –  J. Pablo Fernández Oct 22 '10 at 9:09
    
That's exactly it. And it is awesome. And it's not only Google, but rather with many other websites too, as far as I'm concerned. I've noticed it on other places as well. –  Mussnoon Oct 22 '10 at 13:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.