Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

Search results:

  • 218m - "blog post"
  • 204m - blog post

I expected it to be the other way around, at least.

share|improve this question
    
I completely misread this and posted an answer for the opposite question! –  ChrisF Nov 20 '10 at 13:00
add comment

2 Answers

up vote 3 down vote accepted

This is a bug in Google Instant (Google would probably say it's a feature). Disabling Google Instant should fix it for you.

When I'm signed in to my account and I use Google Instant, I get incorrect results (i.e. more results for the quoted version of the query). If I disable Google Instant, or I use an incognito window in Chrome (using Google Instant, but not logged in), I get the correct results.

Google Instant is described as:

Use Google Instant — predictions and results appear while typing

Signed-in users can remove personalized predictions from their Web History.

What's weird is that I'm using a Google Apps account which has the entire Web History feature disabled, however, it is still obviously tracking personalized suggestions.

If I disable, then enable, Google Instant, it seems like the results are fixed. However, this is probably only temporary.

I have come across this problem in other situations as well such as when I search for the exact text that I know is on a website, but I simply don't get the result from my search. It's extremely frustrating since then you think it's a problem with your query and you can spend a lot of time trying to figure it out. Then you try it on another computer (or an incognito window in Chrome) and there's the result. I hope Google will eventually realize that their attempt at being "smart" is anything but that.

By the way, I have always had web history disabled (since I hate those kind of situations as described above), but have Google Instant enabled (since I like being to search fast). However, if I run into it a lot, I may just disable Google Instant permanently.

share|improve this answer
add comment

There must be something wrong with your search settings. When I search, I get normal results:

  • "blog post": 223m
  • blog post: 1030m
share|improve this answer
    
Are you using Google Instant? –  Senseful Nov 20 '10 at 20:11
    
No, I don't. . . –  Mehper C. Palavuzlar Nov 20 '10 at 20:15
    
That's probably the reason you are seeing different results than OP (see my answer for more info). –  Senseful Nov 20 '10 at 20:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.