0

About 3 weeks ago I began to have this problem occur whenever I copy text from a Google Docs document in Chrome browser and paste it into a text editor. (Technically it's a plain text field within another program but the same thing happens when I paste to Windows Notepad.) What is odd is that not all the line breaks are doubled, but only the ones that create vertical whitespace, that is, whenever I hit Enter twice in a row or more, all line breaks after the first one end up doubled when it's pasted.

To provide a visual example, this original Google Docs text:

Line 1
Line 2

Line 3


Line 4

comes out like this when pasted into Notepad:

Line 1
Line 2


Line 3




Line 4

So the one blank line between Lines 2 and 3 becomes two blank lines, and the two blank lines between Lines 3 and 4 become four blank lines, but the line break from hitting Enter at the end of Line 1 does not become one blank line between Lines 1 and 2. This also happens when I paste into WordPad, but when I paste into Word it comes out like the original. This made me think that it's some additional web formatting that Word is "smart" enough to strip out but that the text editors leave in. However, I tried the "Clear Formatting" option in Google Docs and have tried pasting with Ctrl+Shift+V and neither fix the issue. In terms of Google Docs settings, my line spacing defaults are set to single spaced with 0 pts spacing before and after the paragraph.

Any ideas what's happening here and how I can remedy it?

0

It looks like Google is going to be rolling out an update which is supposed to fix the issue. In the meantime, I ended up using a workaround which was satisfactory for me, though a little extra time-consuming. I read a few places about "soft returns" AKA "manual line breaks" which is what happens when you do a Shift+Enter (or Shift+Return). I had heard of these before but never knew what practical use they had. I replaced all the vertical whitespace-creating line breaks (wherever I had previously hit Enter on a blank line) with Shift+Enter soft returns and when I copy-pasted the document into the text editor this time it did not add the extra line breaks. I was thinking about trying to do a search and replace with regular expressions to save myself all the manual edits but now it looks like I may not have to if the update works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.