1

Facebook expands the links in a post with a link preview. However if you want to post in multiple languages then the link preview is the one taken from the language at the top.

Thus you can not have a link preview for each of the languages that you are translating your post, which makes it quite silly to have such a feature of link preview if you cannot have one for each language of your post.

E.g. If I start writing my comment to be posted in English and I add a link to www.cnn.com, the link will be expanded at the bottom, but then when I translate the post and add the French translation even if I add the link www.lemonde.fr in my FR translated comment, the link preview still shows the info about cnn and after posting the users with French as their Facebook language get to see the cnn expanded preview link at the bottom of my post in French.

I find this an overlook from Facebook that has many other buggy features for multilingual content.

Is there a solution or a workaround to allow me to have separate preview links for each language?

I have tried posting separately, one post per language and restricting the language, but after testing this part is buggy as well (e.g. users with language French see posts in English and not the my manually translated post in French).

  • @user0 Such minor fixes on old(ish) posts aren't really useful. While these grammatical errors can be bothersome, this is overall a very good post, and what you did didn't really improve the readability. – jonsca Jul 23 '18 at 22:31
2

I can confirm that the bug is there with Facebook for the link preview in multilingual posts. It's so silly and so easy to fix it...

The workaround is the one that you mentioned, to post with audience restriction based on language. Thus one post for each language.

You should be doing one more thing though, in your Page Settings, disable the Automatic Translation. Even with the automatic translation disabled, after you post in a particular language, next to the post there is a button that you can click to "Turn off" translations. I do this immediately after I post, I turn off the translations.

I tested the above and it's working, the posts reach only the intended targeted language audience.

However, recently, I can't find anymore the way to restrict a post based on the language, it used to be in the "Restricted Audience" tab. I've just discovered it today that facebook has removed this useful option. In any case the above used to be the way to post and restricting the post only to a targeted language.

If it's confirmed (at least for me it's not visible anymore), that facebook removed the Language from the "Restricted Audience" then I'm afraid there is no other way to post on Facebook only for a particular set of language speakers.

Basically Facebook does not really care about the more professional users like you and me that want to translate and target their messages to their multilingual audience.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.