If I want give access to a Google Docs by sending an invitation email from Google Docs (link sharing enabled), when the recipient opens the link from the email, it only allows them to view it, and requires in bold red letters that they must log in to be able to edit it. Which is the opposite of what it said when creating the invitation: Access:Anyone (no sign-in required) Can edit

How to make it send an URL that works as advertised?


  • I (the document owner) open the document in my browser
  • I click Share
  • click Advanced
  • set Who has access to : Anyone who has the link can edit (that is: Link sharing is On , Access:Anyone (no sign-in required) Can edit)
  • add email addresses to the Invite people: field (Notify people is enabled by default)
  • add a message like: This is the document we talked about...
  • click Send


The link sent to the recipients opens the Docs, but does not allow editing unless they log in to Google.

What I found out:

  • The culprit is the invite=xyZFOO parameter in the URL. If it is deleted and the resulting URL opened, it works (the Docs is displayed and can be edited).
  • it seems Google Docs appends this parameter to the URL in the invitation mail based on the recipient address (whether it is a Google account or not - for Google accounts it sends a "working" URL, for other it appends this invite parameter), but it is not consistent (or I am running out of test recipients)
  • if I enable Send a copy to myself then the URL sent to me is always without the problematic parameter

Is there a way to "just make it work"?

In my situation asking the recipients to manipulate an URL is the same as asking them to perform brain surgery.

PS: Example links:


PPPS: As noted in comments the links now both allow editing without logging in. I created a new test file and links for it:

Now for me the first one requires logging in to edit, while the seconds does not. I guess after a while it starts to work as expected. Please someone try the second link (the one labeled "test 2 - requires login")

  • I was able to access both test 2 links and edit them in incognito mode without signing in my account.
    – Rubén
    Sep 8 '17 at 16:32
  • 3
    I'm voting to close this question as off-topic because the issue could not be reproduced as of 9/8/2017.
    – jonsca
    Sep 21 '17 at 0:50
  • 2
    @jonsca It seems Google added and extra step if a recipient does not have a Google account: either Send an invitation ("Recipient must sign in with a Google account within 14 days to edit.") or "Send the link (no sign-in required)". So the problem is solved. Sep 21 '17 at 17:34

Browse other questions tagged or ask your own question.