3

Bulk deleting emails from Gmail is fine in theory, but in practice it just stalls for me like this:

enter image description here

Just want to select all messages with a particular label and delete them without creating a filter which I would then have to remove.

Very similar to what this user reports:

this error: "Oops.. the system encountered a problem (#502)

Except that my error code is 72830. First I select "all" messages, which is only 100, then:

All 100 conversations on this page are selected. Select all ##### conversations in "label"

I click that, then:

All ###### conversations in "label" are selected. Clear selection

then I click the trash icon to delete them, then:

Confirm bulk action This action will affect all ##### conversations in "label_here". Are you sure you want to continue?

and then I get error 72830 as in the image. Works fine for less than 10k messages, stalls above that consistently.

  • How many messages are we talking about? That's probably just a transient issue. Can you try on a different browser? A different network? Maybe try only half or a quarter of the messages at once? – ale Dec 12 '16 at 13:45
  • 10k, but I've tried folders with 2k. The browser or network would matter? Not sure how to try half, I think it's just "select all" or "select 100" not "select 500"... – Thufir Dec 12 '16 at 13:47
  • The network might matter if there's too much latency or packets dropped between you and Google. The browser might matter if the JavaScript is not quite right. If that's not it then the Google server you're hitting is having trouble, and there's nothing you or I could do about that except wait. – ale Dec 12 '16 at 13:52
  • 1
    what are the steps you are performing when you get the error? – mhoran_psprep Dec 13 '16 at 11:59
  • 1
    You're doing it right. For some reason, the process seems to be timing out. You're probably going to have to delete things in chunks. – ale Dec 13 '16 at 16:25
0

From the library it worked fine after n attempts. Not sure whether to attribute that to networking, OS or browser. On Linux, I was still getting timeouts with the latest Firefox browser, and even from chromium-browser.

"Worked fine" meaning that I was able to delete all e-mails with has:nouserlabels so that everything is in folders. I find it hard to believe, but somehow I have 15+ GB of e-mails. I'll go through attachments and look for large e-mails next.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.