4

I don't have a Facebook account and I don't want any.

The problem is many companies use their public Facebook pages as their websites these days, especially pubs, small shops etc.

When I enter their Facebook pages, this extremely annoying message appears:

enter image description here

I click "Not now", which makes this message a little smaller, but it still covers about 20% of the page. I hate it.

How can I get rid of this once for all?

  • We need a maintained plugin? Or, at least in July 2018, this solution still works: Adding the text @-moz-document domain(www.facebook.com){div[class="_5hn6"]{display:none!important;}} to userChrome.css, see support.mozilla.org/en-US/questions/1125308 – Arno Teigseth Jul 17 '18 at 6:00
  • 1
    @ArnoTeigseth Can you make it an answer? – vojta Jul 17 '18 at 6:01
3

You can delete the tag that create this frame by Inspect Element.

  1. Press F12 or click on the right button of your mouse and select Inspect Element.

  2. Click on the left top icon:

enter image description here

  1. Select the frame to delete:

enter image description here

  1. Press the delete key.

  2. Be happy.

  • I am happy, thanks! And I managed to get even one step farther: with this Firefox plugin I can remove the tag you pointed to with just one click! – vojta Dec 19 '16 at 12:28
1

At least in July 2018, this solution still works: Adding the text

@-moz-document domain(facebook.com){div[class="_5hn6"]{display:none!important;}}

to userContent.css

See also support.mozilla.org/en-US/questions/1125308 but note, it's userContent.css not userChrome.css

In short:

  • Firefox menu Help > Troubleshooting Information > Profile Directory:
  • Open the directory with the button there
  • create or open the folder called "chrome"
  • create a file called userContent.css in the chrome directory, with the contents above. (Beware that if you use notepad for this, it could add a .txt extension, messing up everything. Alternatively, download this file and save it to the chrome directory)
  • restart Firefox

This will work until Facebook decides to change their approach. Or some judge decides it is illegal to show that kind of popups.

  • This is a great solution, because it is permanent.I would upvote twice if I could. – vojta Jul 17 '18 at 14:52
0

I know it's not what you want to hear but - register for Facebook.

Go to security settings and make everything totally private. Don't invite anyone to be your friend. Decline any friend requests you get. After that don't go into Facebook at all - except when you want to check the page for a specific place.

Either that, or choose not to spend your money with any businesses that use Facebook as their webpage.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.