1

After launching an EC2 instance this morning I am still unable to SSH into the instance or ping it with each returning a timed out error:

SSH (executing through Cygwin):

$ ssh -vvv -i "CompStatNotifier.pem" ec2-user@ec2-54-174-71-55.compute-1.amazonaws.com
OpenSSH_7.2p2, OpenSSL 1.0.2h  3 May 2016
debug2: resolving "ec2-54-174-71-55.compute-1.amazonaws.com" port 22
debug2: ssh_connect_direct: needpriv 0
debug1: Connecting to ec2-54-174-71-55.compute-1.amazonaws.com [54.174.71.55] port 22.
debug1: connect to address 54.174.71.55 port 22: Connection timed out
ssh: connect to host ec2-54-174-71-55.compute-1.amazonaws.com port 22: Connection timed out

Ping:

$ ping ec2-54-174-71-55.compute-1.amazonaws.com

Pinging ec2-54-174-71-55.compute-1.amazonaws.com [54.174.71.55] with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 54.174.71.55:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

Within the security group configurations an ICMP rule has been added for 'Echo Response' and 'Echo Request' acting on '0.0.0.0/0' as well as one for SSH access from anywhere under the inbound rules. The network ACL has entries for inbound and outbound traffic for all ports on all traffic on 0.0.0.0/0 set to ALLOW

My security group rules are here (I can't embed images so I have to use links)

Outbound security group rules
Inbound security group rules

I've attempted restarting the instance and launching a new instance using the same AMI but this has not changed the results. On the machine attempting to ping and connect there is an rule allowing any outgoing SSH connections on port 22 in the firewall but I've had no previous issues with SSH. The address used is the one listed under 'Public DNS'.

Additionally, attempting to connect directly through the AWS java client does not work either giving the same error with no further information. I can connect for the first 5 minutes or so once the instance has been launched but at an almost random points the SSH connection will time out and I will be unable to connect to it again getting the results shown in this question.

I'm happy enough to provide any more details that are needed but any help would be appreciated. It may just be a mistake on my part but I couldn't find a solution as of this moment. I've looked through a fair number of other StackOverflow questions asking the same or a similar question but I'm yet to find a working solution but feel free to link to one if you feel it applies.

(This is the third stack exchange site I've posted this to but if it is still in the wrong place let me know and I will move it)

  • 2
    This question was bumped by the Community user. I'm voting to close this question as off-topic because I think that nowadays it's off-topic here because it's not about using a web application as it's defined on help center. If you need help to find if there is a site on Stack Exchange where the question will be on-topic please ask in Meta Stack Exchange. – Rubén Dec 10 '19 at 17:48
-1

It happens with me a lot of times. I actually stopped my Instance and Started again, after few minutes I was able to know that the Public DNS has changed. I tried to SSH with new DNS and still it didn't work. The issue is with AWS itself I think. I created new instance and it worked.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.