If I share a folder in OneDrive with other users, I want them to be allowed to add files, but I do not want the other users to be allowed to delete files. If possible, as owner of the the shared folder, I would like to still be able to delete files.

  • If I give them only "Can View" permissions, they can not add the Folder to their OneDrive and can whether add nor delete files in the Folder, just download the folder.
  • If I give them only "Can Edit" permissions, they can add the Folder to their OneDrive and add/delete files.

So I need the users I share the folder with, to be able to add the folder to their OneDrive, to add files, but not to be able to delete files.


Note: This answer is with regards to the permissions on the local file itself. When I answered the question it was not clear to be they were talking about the permissions on the cloud copy of the file.

Within the properties of the folder in question do the following:

  1. Click Security
  2. Click Advanced
  3. Click on the Principal you wish to change the permissions for.
  4. Click Edit

    enter image description here

  5. Click 'Show Advanced Permissions`

  6. Remove the Delete permission

enter image description here

  1. Click Ok
  2. Within the Advanced Security Settings window hit Apply
  3. Close all Windows.

As an Administrator user you might have to remove the inheritance on the folder in order for the View button to change to an Edit button. For the purposes of this answer I copied and pasted the Edit button into my screenshot.

This approach can still be used. If they cannot delete the local file, then the cloud copy, cannot be deleted (unless they go to the browser and delete it).

  • I will test this. I thought I will be able to set these permissions online in the browser.
    – user69453
    Jan 16 '17 at 18:43
  • No i did not mean on the local machine, I did not see that my question can be interpreted that way. I will edit my question.
    – user69453
    Jan 16 '17 at 19:14
  • This is not the answer, it's about cloud.
    – MaXi32
    Sep 1 '20 at 17:35
  • @MaXi32 - This question was migrated after I submitted my answer. I am not prepare to modify my answer from 3 and half years ago.
    – Ramhound
    Sep 1 '20 at 18:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.