An applet I have for posting from Instagram to Twitter isn't working. When I click "check now" all I get is a message saying "We can't check your applet right now" and it always give the same message. The applet never run and the only item that appears in the activity log is the creation of the applet. I used to have applets like this one which worked perfectly, what can it be?

  • Have you tried contacting their support? They can supply more information on the errors. I did it a few times and got a bit more detailed error that helped me figure out the problem. Commented Jun 5, 2018 at 10:08
  • Maybe there's a usage limit from one of the sides? Commented Jun 5, 2018 at 14:20
  • 3 years later and I'm having the same issue. I tried a test post without hashtags as suggested here, but it hasn't fired yet, after running a check. When I run a check it just says "Check completed". I have checked to make sure that the services are connected to the right accounts. I will try to contact support.
    – James Ray
    Commented Dec 19, 2020 at 3:22
  • Honestly I dont remember how these things worked because it's been years since I dont use them but apparently I "solved it" by switching to another free service with the same features.
    – Pablo
    Commented Dec 19, 2020 at 3:26
  • I sent them a Tweet. I have tried three different applets, one that I created myself including the caption and source URL, one by Twitter, and one by Instagram. None of them worked. OK I will try that, but I am skeptical whether it will work if you couldn't get it to work.
    – James Ray
    Commented Dec 19, 2020 at 3:44

1 Answer 1


Do your IG posts have a lot of hashtags? I stumbled across this forum Q bc my latest IG post kept failing to fire IFTTT to Twitter, and I got the same error message as you when I tried to check the applet. After the third time I then tried it again with just a simple "test" caption and suddenly it worked fine. I have posted long captions before so I don't think it was the character limit per se, but I think the problem post couldn't tweet because of something in the caption.

  • Hi, what you wrote sounds like a comment, not an answer. However, I do see that you have some information here that can be relevant as answer. Would you edit you answer to make it fit the site better? Sources and references would be also great. Commented Jun 5, 2018 at 10:00
  • they have zero hashtags
    – Pablo
    Commented Jun 5, 2018 at 10:26
  • BTW, I "solved" this by switching to another similar service (Zapier) but now they have the same problem.
    – Pablo
    Commented Jun 5, 2018 at 10:27
  • 1
    @Pablo if you solved it, even if with another service - it would be great if you right an answer about it, in case someone else encounter it. Although if it doesn't work maybe it's not relevant (but in general) Commented Jun 5, 2018 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.