1

Whenever I write a new post or article, and link to another article or post, the other post/article gets a comment containing a link to and content of the new article. Screenshot of such a comment

The comments section of WordPress shows author as Title and new post link.

For example, I wrote an article on how to root an Android 6 smartphone. Then I wrote another article about Xiaomi. In this article I added a link to the "Root Android 6 smartphone" article, which suddenly has a comment as shown in the screenshot.

How do I avoid creating these automatic comments?

There are no comment plugins except Akismet Anti-Spam (and this plugin does not flag the comment as spam).

1

This is the pingback feature (documentation), which is meant to post a comment on a post when the post is mentioned somewhere else - also on the same blog.

If you want to link to a post on your own blog without pinging it, you can do so by not using the absolute URL when linking. From the documentation:

To prevent self-pings, remove the domain from the link, keeping only the slug — the part of the URL that comes after the “.com.” Instead of this:

http://en.blog.wordpress.com/2009/03/26/twitter-widget use only this:

/2009/03/26/twitter-widget

If you want to completely disable ping-backs (also from other blogs), you can uncheck the Allow pingbacks & trackbacks checkbox when editing a post.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.