On Facebook I decided to show off with the languages I know.
Now, when I click on my "Profile" I can see "Knows French, English, German and 4 others" just under my name.

Problem: My friends can NOT see it. (the point of Facebook is to be seen, right?)

In Privacy Settings, I use "Customize": everything is "Friends only" (except my email address which is "Only me"), which is not very restrictive, so I guess it is not a privacy settings problem.

Any idea what I have to do to make the languages visible?

3 Answers 3


They could still be using the old Facebook UI. which is upgradable http://www.facebook.com/about/profile/.

You also need to make sure

See your likes, activities and other connections

is set to the right privacy level.

You can check the various levels of visibility of your profile.

  • I can't find the "See your likes, activities and other connections" setting in "Choose Your Privacy Settings > Customize settings". Is it in another place I didn't think about? My friend is using the new profile, and still can only see where I live, but not the languages.
    – nic
    Dec 18, 2010 at 2:43
  • @Nicolas It is in Choose Your Privacy Settings > Connecting on Facebook
    – phwd
    Dec 18, 2010 at 13:54
  • Great, that works! Awarding you the bounty :-) Thanks a lot for always giving great tips!
    – nic
    Dec 18, 2010 at 16:07
  • Looks like I have to wait 14 hours before I can give it...
    – nic
    Dec 18, 2010 at 16:09
  • i have same problem languages i speak is not shown on my profile...i do have alot of things limited but the thing is what should i change? i cant just keep my profile open to all of my friends.
    – user12425
    Jul 26, 2011 at 1:36

Unlike posts/comments/messages, changes to settings on your Facebook profile sometimes take several hours before they are seen by everyone. Check again the next day.

  • It has been 5 days already.
    – nic
    Dec 18, 2010 at 2:44

Customize your language settings.You can share it for friends,only me,public or custome.enter image description here

  • I believe the OP says that all settings are set to Friends only. Apr 7, 2015 at 12:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.